Derby
  1. Derby
  2. DERBY-3627

derbynet/DerbyNetAutoStart.java with DerbyNetClient fails intermittently on iseries

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 10.3.1.4, 10.4.1.3
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      iseries; seen with ibm142 & 10.3.1.4; now also ibm16 & 10.4.1.1
    • Bug behavior facts:
      Regression Test Failure

      Description

      I've seen the test derbynet/DerbyNetAutoStart with DerbyNetClient fail on iseries; but I've seen it pass too. Usually it passes when rerun separately by itself, but not always.

      Here's the diff:

          • Start: DerbyNetAutoStart jdk1.6.0 DerbyNetClient derbynetmats:derbynetmats 2008-04-08 20:01:31 ***
            6 del
            < PASSED.
            6 add
            > Server start failed: java.net.ConnectException : Error connecting to server xxxFILTERED_HOSTNAMExxx on port 1527 with message A remote host refused an attempted connect operation..
            > java.sql.SQLException: java.net.ConnectException : Error connecting to server xxxFILTERED_HOSTNAMExxx on port 1527 with message A remote host refused an attempted connect operation..
            > Caused by: org.apache.derby.client.am.DisconnectException: java.net.ConnectException : Error connecting to server xxxFILTERED_HOSTNAMExxx on port 1527 with message A remote host refused an attempted connect operation..
            > ... 6 more
            > Caused by: java.net.ConnectException: A remote host refused an attempted connect operation.
            > ... 12 more
            > FAILED.
            Test Failed.
          • End: DerbyNetAutoStart jdk1.6.0 DerbyNetClient derbynetmats:derbynetmats 2008-04-08 20:02:32 ***

      This looks quite similar to DERBY-2178 (which is logged as specific for ibm15, but in fact has a comment about ibm142 also showing the problem, and there too, the problem appears intermittent based on subsequent comments).

      I think this may turn out to be a test issue, but for now marking as bug.

      1. derby.log
        11 kB
        Myrna van Lunteren
      2. derbynet.log
        0.2 kB
        Myrna van Lunteren
      3. DerbyNetAutoStart.diff
        3 kB
        Myrna van Lunteren
      4. DerbyNetAutoStart.out
        0.8 kB
        Myrna van Lunteren
      5. DerbyNetAutoStart.tmp
        3 kB
        Myrna van Lunteren

        Issue Links

          Activity

          Myrna van Lunteren added a comment -

          It really looks like a duplicate of DERBY-2178, except that the error message doesn't get properly unwrapped on the z/OS machine.

          Myrna van Lunteren added a comment -

          Attaching all files that may have info of the one time I saw when a rerun of the test by itself also failed.


            People

            • Assignee:
              Unassigned
              Reporter:
              Myrna van Lunteren
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development