Derby
  1. Derby
  2. DERBY-3606

invalid checksum happened in Derby 10.2.2.0

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 10.2.2.0
    • Fix Version/s: None
    • Component/s: Miscellaneous
    • Labels:
      None
    • Environment:
      windows xp, notebook, possibly broken hard drive!
    • Urgency:
      Urgent
    • Bug behavior facts:
      Crash, Seen in production

      Description

      one of my customers gets on a notebook the following exception:

      ----------------------------------------------------------------
      2007-03-17 09:01:53.042 GMT:
      Booting Derby version The Apache Software Foundation - Apache Derby - 10.2.2.0 - (485682): instance c013800d-0111-5f21-a736-000002cd2118
      on database directory C:\Programme\merkisoft\kursverwaltung\database\kurs
      Database Class Loader started - derby.database.classpath=''
      ------------ BEGIN SHUTDOWN ERROR STACK -------------
      ERROR XSDG2: Invalid checksum on Page Page(28,Container(0, 1248)), expected=3'455'715'557, on-disk version=3'357'396'866, page dump follows: Hex dump

      hex dump => see attachment

      i'm using the embedded version together with hibernate on the notebook.
      when i transfer the db to my pc and execute select * from <all tables> i get no errors at all.
      we checked the disk about 3 times (with error correction): no result and it still happens.
      when i create a new db on the notebook it happens after a while again.
      the db is about 35 mb. i could put it somewhere for developers (please email me).

      i've seen someone else having a similar problem but i couldn't find a solution yet.

      any help is very welcome!

      ------------------

      hi bryan

      thanks for the quick reply! i tried to answer your questions. i hope it
      helps.

      > Does this happen for this customer over and over?
      > Or did it happen only once?

      yes only that, but it happend 6 times.

      > Is the customer able to provoke the error on demand?

      i tried without success but i keep testing it.

      > Can you relate the exception to any particular action that the customer
      > is taking in your application?

      till now no.

      > If it has happened multiple times, is it always the same page on
      > the same container? Or is the location different each time?

      we installed the app serveral times and i think the following lines are per
      installation (so per installation it happend on the same page):

      org.hibernate.util.JDBCExceptionReporter - Invalid checksum on Page
      Page(28,Container(0, 1248)), expected=3'455'715'557, on-disk
      version=3'357'396'866, page dump follows: Hex dump:
      org.hibernate.util.JDBCExceptionReporter - Invalid checksum on Page
      Page(461,Container(0, 1248)), expected=3'908'279'257, on-disk
      version=137'782'528, page dump follows: Hex dump:
      org.hibernate.util.JDBCExceptionReporter - Invalid checksum on Page
      Page(482,Container(0, 1248)), expected=4'113'528'744, on-disk
      version=44'301'386, page dump follows: Hex dump:
      org.hibernate.util.JDBCExceptionReporter - Invalid checksum on Page
      Page(702,Container(0, 944)), expected=2'598'292'545, on-disk
      version=3'174'535'138, page dump follows: Hex dump:
      org.hibernate.util.JDBCExceptionReporter - Invalid checksum on Page
      Page(2767,Container(0, 944)), expected=2'067'623'629, on-disk
      version=2'180'532'620, page dump follows: Hex dump:
      org.hibernate.util.JDBCExceptionReporter - Invalid checksum on Page
      Page(99,Container(0, 1248)), expected=242'030'294, on-disk
      version=3'389'026'885, page dump follows: Hex dump:

      > When the exception happens, are there any follow-on symptoms?

      yes, my app crashes ;-((
      i'm not shure how well i reinit the db connection.

      > Or did > the application seem to behave properly after the user shut it
      > down and restarted it? Can the customer later access the data properly
      > on their notebook? Or do you have to move the files to another machine
      > in order to access the data?

      restarts did not help as far as i know. but but when i copied it onto my
      harddrive it was ok.

      > thanks,

      thank you!
      fabian

      thanks
      fabian

        Issue Links

          Activity

          Knut Anders Hatlen added a comment -

          The summary says version 10.3.2.2, but the affects-version field and derby.log say 10.2.2.0. Should the summary be changed?

          Knut Anders Hatlen added a comment -

          Changed the version number in the summary to match the Affects Version field and derby.log.

          Kathey Marsden added a comment -

          Is this a duplicate of DERBY-3607?

          Knut Anders Hatlen added a comment -

          Duplicate of DERBY-2475, I think.

          Tiago R. Espinha added a comment -

          Triaged for 10.5.2. Checked Crash and Seen in production. Changed components to Miscellaneous.

          Linking to DERBY-3607 and DERBY-2475 as duplicates.

          Kathey Marsden added a comment -

          Comments indicate this is a duplicate of DERBY-3607. Resolving as such.


            People

            • Assignee:
              Unassigned
              Reporter:
              Shahbaz
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development