Derby
  1. Derby
  2. DERBY-3594

socket reset failure causing 17 networkserver tests to fail on ibm iseries

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.4.1.3
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      IBM iseries, I tried this with a sun 1.4.2 jdk and ibm 1.6 jvm.

      Description

      With the beta build for 10.4.1.0 (637204M) I saw 19 failures that I did not see with 10.3.2.1, 17 of which show some kind of timeout due to a socket reset.

      For example:
      1) SecureServerTest( Opened = false, Authenticated= false, CustomDerbyProperties= null, WildCardHost= null )junit.framework.AssertionFailedError: Timed out waiting for network server to start:Spawned SpawnedNetworkServer exitCode=134
      STDERR:
      java.io.IOException: A connection with a remote socket was reset by that socket.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at java.io.IOException.<init>(IOException.java:41)
      at java.io.FileInputStream.readBytes(Native Method)
      at java.io.FileInputStream.read(FileInputStream.java:177)
      at org.apache.derbyTesting.junit.SpawnedProcess$2.run(SpawnedProcess.java:179)
      at java.lang.Thread.run(Thread.java:619)

      STDOUT:
      java.io.IOException: A connection with a remote socket was reset by that socket.
      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Exception.<init>(Exception.java:41)
      at java.io.IOException.<init>(IOException.java:41)
      at java.io.FileInputStream.readBytes(Native Method)
      at java.io.FileInputStream.read(FileInputStream.java:199)
      at java.io.BufferedInputStream.fill(BufferedInputStream.java:218)
      at java.io.BufferedInputStream.read1(BufferedInputStream.java:258)
      at java.io.BufferedInputStream.read(BufferedInputStream.java:317)
      at java.io.FilterInputStream.read(FilterInputStream.java:90)
      at org.apache.derbyTesting.junit.SpawnedProcess$2.run(SpawnedProcess.java:179)
      at java.lang.Thread.run(Thread.java:619)

      at java.lang.Throwable.<init>(Throwable.java:196)
      at java.lang.Error.<init>(Error.java:49)
      at junit.framework.AssertionFailedError.<init>(AssertionFailedError.java:11)
      at org.apache.derbyTesting.junit.NetworkServerTestSetup.setUp(NetworkServerTestSetup.java:196)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:18)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)

      I saw no useful information in derby.log files, it could be that there is some authentication issue playing here.

      1. socketfailures.txt
        40 kB
        Myrna van Lunteren
      2. env_report.txt
        2 kB
        Myrna van Lunteren

        Activity

        Myrna van Lunteren created issue -
        Myrna van Lunteren added a comment -

        stack traces of the socket failures.

        Myrna van Lunteren made changes -
        Field Original Value New Value
        Attachment socketfailures.txt [ 12379359 ]
        Myrna van Lunteren made changes -
        Derby Info [Regression]
        Myrna van Lunteren added a comment -

        environment details

        Myrna van Lunteren made changes -
        Attachment env_report.txt [ 12379360 ]
        Myrna van Lunteren made changes -
        Component/s Regression Test Failure [ 12310664 ]
        Myrna van Lunteren added a comment -

        I'm unmarking this as a regression - assuming we interpret regression as code regression, and adding Test component.

        I think the issue is that some new testing code has gone in that has a cut-off time that's just too fast for my slower machine.
        Especially in the class org.apache.derbyTesting.junit.SpawnedProcess there are a number of Thread.sleep(500) statements - and it's just short.

        I have encountered troubles like this before, and I had suggested modifying the code in NetworkServerTestSetup to default to the current time settings to be configurable...I think Dan at the time voice concern that there may be a bug hiding.
        I don't think so, and I think at least increasing the number of tries before a timeout is concluded, would help for NetworkServerTestSetup.

        And I think SpawnedProcess needs to have a setup similar to NetworkServerTestSetup where there are some tries before it is timed out (don't want to have the sleep increase, necessarily, for that would slow everyone down, even faster machines).

        Myrna van Lunteren made changes -
        Component/s Regression Test Failure [ 12310664 ]
        Component/s Test [ 11413 ]
        Derby Info [Regression]
        Myrna van Lunteren added a comment -

        I'm marking this cannot reproduce because I didn't see this message during the 10.5.2.0 testing cycle.
        But I've seen this message pop up in other environments even with 10.5.2.0...But if I see it again in a next version I can reopen at that time.

        Myrna van Lunteren made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]
        Myrna van Lunteren made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gavin made changes -
        Workflow jira [ 12428129 ] Default workflow, editable Closed status [ 12800916 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        480d 14h 48m 1 Myrna van Lunteren 28/Jul/09 23:02
        Resolved Resolved Closed Closed
        533d 23h 41m 1 Myrna van Lunteren 13/Jan/11 21:44

          People

          • Assignee:
            Unassigned
            Reporter:
            Myrna van Lunteren
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development