Derby
  1. Derby
  2. DERBY-303

derbynet/testconnection.java fails

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.1.1.0
    • Fix Version/s: 10.1.1.0
    • Component/s: Test
    • Labels:
      None
    • Environment:
      Seem to occur on several platforms

      Description

      When I run the testsuite, derbynet/testconnection.java fails.
      testconnection.tmp contains the following:

      Testing testconnection
      org.apache.derby.drda.NetworkServerControl ping
      Could not connect to Derby Network Server on host localhost, port 1527.
      java.lang.IllegalThreadStateException: process hasn't exited
      at java.lang.UNIXProcess.exitValue(UNIXProcess.java:116)
      at org.apache.derbyTesting.functionTests.tests.derbynet.testconnection.execCmdDumpResults(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.derbynet.testconnection.execCmdDumpResults(Unknown Source)
      at org.apache.derbyTesting.functionTests.tests.derbynet.testconnection.main(Unknown Source)

      1. DERBY-303.diff
        0.6 kB
        David Van Couvering

        Activity

        Andrew McIntyre added a comment -

        Confirmed as fixed by Øystein.

        Andrew McIntyre added a comment -

        Resolved issue on my Linux box, committed patch with revision 171164. Will close issue after waiting for Ole's results.

        Andrew McIntyre added a comment -

        This is also failing on a Linux-x86 box that I have. I will also test this patch and provide feedback.

        David Van Couvering added a comment -

        Looking at the very helpful test results from Ole, it appears this bug only occurs on Solaris 10x86.
        I can't reproduce on any platforms I have available. However, a code inspection shows that
        I am missing a call to Process.waitFor() The attached patch adds this call; Oystein, can you
        see if this fixes it for you on your Solaris 10 x86 box?

        David Van Couvering added a comment -

        This definitely worked in my sandbox when I tested it; I will work on this ASAP.

        Øystein Grøvlen added a comment -

        This seems to be a regression from DERBY-214.
        The call to exitValue that fails was added in DERBY-214.

        It may seem like the preceeding calls to ProcessStreamResult.Wait() does not guarantee that the process has terminated.


          People

          • Assignee:
            David Van Couvering
            Reporter:
            Øystein Grøvlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development