Derby
  1. Derby
  2. DERBY-2899

Reoccurrence of DERBY-2434: HarnessJavaTest fails on UTF-8 locale.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 10.3.1.4
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      Microsoft(R) Windows(R) Server 2003, - 5.2.3790 Service Pack 2
      WindowsNT 2 5
      Sun jvm 1.5.0_07-b03

      Also seen on windows2000 and Windows Vista

      Description

      There was 1 failure:
      1) statementJdbc20(org.apache.derbyTesting.functionTests.tests.jdbcapi.JDBCHarnessJavaTest)junit.framework.ComparisonFailure: Output at line 3 expected:<... parameter value '-1[,]000' for Statement.s...> but was:<... parameter value '-1[?]000' for Statement.s...>
      at org.apache.derbyTesting.functionTests.util.CanonTestCase.compareCanon(CanonTestCase.java:100)
      at org.apache.derbyTesting.functionTests.util.HarnessJavaTest.runTest(HarnessJavaTest.java:91)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:88)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:24)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:21)
      at junit.extensions.TestSetup.run(TestSetup.java:25)
      at org.apache.derbyTesting.junit.BaseTestSetup.run(BaseTestSetup.java:57)

      Also see logging under http://dbtg.thresher.com/derby/test/10.3.1.0_RC/jvm1.5/testing/testlog/w2003/548006-suitesAll_diff.txt

        Issue Links

          Activity

          Knut Anders Hatlen added a comment -

          Duplicate of DERBY-957.

          Henri van de Scheur added a comment -

          Since Derby-957 was fixed and this was a duplicate, this one can also be closed.


            People

            • Assignee:
              Unassigned
              Reporter:
              Henri van de Scheur
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development