Derby
  1. Derby
  2. DERBY-2894

calling DatabaseMetaData.getColumns() with % for matching column character in a territory based collated db does not work in 1.4.2 jvms

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.3.1.4
    • Fix Version/s: 10.3.1.4
    • Component/s: SQL
    • Labels:
      None

      Description

      calling DatabaseMetaData.getColumns(null, "APP", "CUSTOMER", "%") returns no rows for a valid APP.CUSTOMER table
      in ibm142 and sun142 jvms, for databases created with territory based collation, fails in all 3 cases we test in the
      CollationTest2.java junit test.

      Since this is a system catalog query I am surprised the result is affected at all by collation, so there may be a derby bug
      in the metadata routines, or elsewhere. Mamta, could you comment if you believe this should work already - or if there
      is more work to do in this area.

      I will soon checkin a test case into the CollationTest2.java unit test that shows this. For now I will either comment out the
      entire test, or if I can figure out how to not run it on 142 I will do that.

      This issue was first reported as DERBY-2703 but it was reported as a subtask of DERBY-1478. But since it really is a bug, I am re-reporting it at the top level so it can be tracked as open bug.

        Issue Links

          Activity

          Mamta A. Satoor created issue -
          Daniel John Debrunner made changes -
          Field Original Value New Value
          Link This issue relates to DERBY-2896 [ DERBY-2896 ]
          Daniel John Debrunner added a comment -

          DERBY-2896 has the metadata query for getTables() failing with a 42818 error, on a ibm 1.5 vm.

          Mamta A. Satoor added a comment -

          Can someone try this in sun142 environment because I just uncommented following from CollationTest2.runDERBY_2703 and didn't see any problems when running CollationTest2 with Sun jdk142
          //if (is142JVM())
          // return;

          $ which java
          c:/p4clients/main/jdk142/bin/java.exe

          Mike Matrigali made changes -
          Link This issue relates to DERBY-1478 [ DERBY-1478 ]
          Mike Matrigali made changes -
          Link This issue relates to DERBY-2703 [ DERBY-2703 ]
          Mike Matrigali added a comment -

          The 2 test cases passed for me. I just reenabled the test cases to run against all jvm's in the trunk:
          m2_ibm142:43>svn commit

          Sending java\testing\org\apache\derbyTesting\functionTests\tests\lang\Col
          lationTest2.java
          Transmitting file data .
          Committed revision 555421.

          Mike Matrigali added a comment -

          I tried it out in the 10.3 branch also and the bug is fixed. I would like to back port the test change and mark this as fixed or at least no longer reproduces as soon as it has run through the publicly posted nightly runs.

          Mike Matrigali made changes -
          Assignee Mike Matrigali [ mikem ]
          Mike Matrigali added a comment -

          This issue no longer reproduces, it must have been fixed by subsequent Collation work, but not sure what change.

          Mike Matrigali made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Fix Version/s 10.3.1.4 [ 12312590 ]
          Resolution Cannot Reproduce [ 5 ]
          Kathey Marsden made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Gavin made changes -
          Workflow jira [ 12407569 ] Default workflow, editable Closed status [ 12799972 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          27d 23h 48m 1 Mike Matrigali 31/Jul/07 19:35
          Resolved Resolved Closed Closed
          1269d 23h 15m 1 Kathey Marsden 21/Jan/11 17:50

            People

            • Assignee:
              Mike Matrigali
              Reporter:
              Mamta A. Satoor
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development