Derby
  1. Derby
  2. DERBY-2553

values SYSCS_UTIL.SYSCS_GET_RUNTIMESTATISTICS() returns null in test ScrollCursors1Test when run against network server

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 10.3.1.4
    • Fix Version/s: None
    • Component/s: Network Client
    • Urgency:
      Low
    • Issue & fix info:
      Newcomer, Repro attached
    • Bug behavior facts:
      Embedded/Client difference

      Description

      Call to runtimestatistics in the new test ScrollCursors1Test returns null value when run against network server.
      Look for the reference to this bug near the following code. I was not able to reproduce this outside of the test.

      rs2 = s.executeQuery("values SYSCS_UTIL.SYSCS_GET_RUNTIMESTATISTICS()");
      rs2.next();

      if (usingEmbedded())

      { // not sure why I get a null rts with network server. RuntimeStatisticsParser rts = new RuntimeStatisticsParser(rs2.getString(1)); rs2.close(); assertEquals(Connection.TRANSACTION_READ_COMMITTED, rts.getIsolationLevel()); assertTrue(rts.usedTableScan()); assertTrue(rts.isScrollInsensitive()); }

        Issue Links

          Activity

          Hide
          Kathey Marsden added a comment -

          Triage for 10.8. Still seems to be an issue.

          Show
          Kathey Marsden added a comment - Triage for 10.8. Still seems to be an issue.
          Hide
          Myrna van Lunteren added a comment -

          Interesting. I have been poking at DERBY-1342 for a couple of days now, and so I noticed a couple of different tests getting runtimestatistics fine with client. So I thought I'd double check this, and with the if (embedded) condition commented out, the test ran fine (built classes, insane). I also checked InbetweenTest, which has the same check for if (embedded) (as do a number of other tests).

          Did you actually try it out also?

          Show
          Myrna van Lunteren added a comment - Interesting. I have been poking at DERBY-1342 for a couple of days now, and so I noticed a couple of different tests getting runtimestatistics fine with client. So I thought I'd double check this, and with the if (embedded) condition commented out, the test ran fine (built classes, insane). I also checked InbetweenTest, which has the same check for if (embedded) (as do a number of other tests). Did you actually try it out also?

            People

            • Assignee:
              Unassigned
              Reporter:
              Kathey Marsden
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:

                Development