Derby
  1. Derby
  2. DERBY-2348

testProtocol(org.apache.derbyTesting.functionTests.tests.derbynet.NetHarnessJavaTest)j failed

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.3.1.4
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      This test failed on ibm142/ibm15.
    • Bug behavior facts:
      Regression Test Failure

      Description

      3) testProtocol(org.apache.derbyTesting.functionTests.tests.derbynet.NetHarnessJavaTest)junit.framework.ComparisonFailure: Output at line 26 expected:<......> but was:<...9 SECMEC=...>
      at org.apache.derbyTesting.functionTests.util.CanonTestCase.compareCanon(CanonTestCase.java:100)
      at org.apache.derbyTesting.functionTests.util.HarnessJavaTest.runTest(HarnessJavaTest.java:91)
      at org.apache.derbyTesting.junit.BaseTestCase.runBare(BaseTestCase.java:76)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)
      at junit.extensions.TestDecorator.basicRun(TestDecorator.java:22)
      at junit.extensions.TestSetup$1.protect(TestSetup.java:19)
      at junit.extensions.TestSetup.run(TestSetup.java:23)

        Activity

        Rajesh Kartha added a comment -

        I also noticed that in runs on ibm142 and ibm15, due the the failure of the above test, the teardown at the end also fails
        with the following exception.

        2) derbynet: old harness java testsjunit.framework.AssertionFailedError: extin\connect.inc
        at org.apache.derbyTesting.junit.DropDatabaseSetup.removeDir(DropDatabaseSetup.java:102)
        at org.apache.derbyTesting.junit.DropDatabaseSetup.access$000(DropDatabaseSetup.java:38)
        at org.apache.derbyTesting.junit.DropDatabaseSetup$1.run(DropDatabaseSetup.java:77)
        at java.security.AccessController.doPrivileged(AccessController.java:193)
        at org.apache.derbyTesting.junit.DropDatabaseSetup.removeDirectory(DropDatabaseSetup.java:74)
        at org.apache.derbyTesting.junit.SupportFilesSetup.tearDown(SupportFilesSetup.java:106)
        at junit.extensions.TestSetup$1.protect(TestSetup.java:20)
        at junit.extensions.TestSetup.run(TestSetup.java:23)

        I am not creating a separate JIRA for the NetHarnessJavaTest as it seems to be related to an earlier test failure.

        Kathey Marsden added a comment -

        Unchecking Regession checkbox as this is not a confirmed product regression

        Kristian Waagan added a comment -

        Can anyone explain to me what is the problem with the testProtocol test?
        I'm looking at removing references to the old harness in the new harness, and testProtocol is the only user of TestConfiguration.runningInDerbyHarness().
        From this issue, the last problem seem to be related to running on IBM JVMs, but I don't have these easily available.

        Myrna van Lunteren added a comment -

        From the history, I can only conclude that the problem described in this bug went away once the test was put back to run with the old test harness. (see revision http://svn.apache.org/viewvc?view=rev&revision=521949).

        I have access to IBM jvms, and I could undo that change (i.e. run the test through the NetHarnessJavaTest) and see if the problem still occurs if that info would help?

        Or maybe another look at DERBY-2031 would be a more thorough approach. If I remember correctly (without properly reading all the notes) Julo wrote a patch but there was some concern with it.

        Kristian Waagan added a comment -

        Thanks Myrna.

        I'm thinking about taking another stab at rewriting this test into JUnit. More specifically, I want to try doing this using the package-private test strategy, which I spent some time on lately to get up and running.

        Because there is still a long way way to go, I will develop this test in parallel to the existing TestProto (and the actual tests using it).
        Please look at DERBY-2031 for more details.

        Kathey Marsden added a comment -

        Resolving this CannotReproduce as attempts to reproduce the failure seem to have failed since 2007


          People

          • Assignee:
            Unassigned
            Reporter:
            Suresh Thalamati
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development