Derby
  1. Derby
  2. DERBY-22

Exception XCL16 incorrectly raised for ResultSet of method return after nested commit.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.0.2.0
    • Fix Version/s: None
    • Component/s: SQL
    • Labels:
      None

      Description

      Reporting for Daniel John Debrunner.

      A static method calls commit() with the nested connection and
      then returns a value to the outer statement. Processing this
      result set incorrectly hits a XCL16 exception. Logically the
      result set is created after the commit, since the value is
      returned after the commit.

      1. derby22reproattempt.zip
        1 kB
        Kathey Marsden
      2. derby22reproattempt.zip
        1 kB
        Kathey Marsden

        Activity

        Shreyas Kaushik added a comment -

        Can there be a repro posted for this here?

        Kathey Marsden added a comment -

        Attached is an attempted repro of this issue based on the description, but it doesn't seem to fail. Perhaps it has been already fixed or perhaps I errored in trying to reproduce the issue. Dan could you comment on which might be the case.

        Thanks

        Kathey

        Daniel John Debrunner added a comment -

        Try with the connection in close cursors on commit mode.

        Kathey Marsden added a comment -

        Here is another attempt to reproduce, setting the connection to CLOSE_CURSORS_AT_COMMIT, but still cannot reproduce. Ideas?

        Kathey Marsden added a comment -

        Was not able to reproduce this error. The issue can be reopened if we get a repro.

        Kathey


          People

          • Assignee:
            Unassigned
            Reporter:
            Tulika Agrawal
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development