Derby
  1. Derby
  2. DERBY-2290

derbyall/derbylang/logStream reports 'derby.log has content ? false'

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 10.1.3.2, 10.3.1.4
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
    • Bug behavior facts:
      Regression Test Failure

      Description

      derbyall/derbylang/logStream has failed intermittently on Windows XP with the following signature since ~ svn 494516.

      </signature>
      Failure Details:

                      • Diff file derbyall/derbylang/logStream.diff
          • Start: logStream jdk1.5.0_05 derbyall:derbylang 2007-02-04 20:51:17 ***
            3a4,8
            > derby.log has content ? false
            > SHUTDOWN Derby
            > SHUTDOWN :Derby system shutdown.
            > derby.log exists ? true
            > derby.log is directory ? false
            5,9d9
            < SHUTDOWN Derby
            < SHUTDOWN :Derby system shutdown.
            < derby.log exists ? true
            < derby.log is directory ? false
            < derby.log has content ? true
            Test Failed.
          • End: logStream jdk1.5.0_05 derbyall:derbylang 2007-02-04 20:51:21 ***
            </signature>

        Activity

        Mike Matrigali added a comment -

        what version is this happening in?

        Kathey Marsden added a comment -

        I am seeing this in 10.1.3.2

        Kathey Marsden added a comment -

        Myrna suggested I change the affects version back to include 10.3. Also unchecking the regression flag since this has apparently been around for a while.

        Myrna van Lunteren added a comment -

        This problem is not seen with the converted version, engine/ErrorStreamTest, so it's fixed with the conversion.

        I think this still occurs occassionally with 10.1, 10.2 or 10.3 (see for instance DERBY-4100), but it's rare, and we cannot backport the conversion to 10.1 anyway. Perhaps someone with enough drive will attempt a backport to 10.3 sometime - they can reopen DERBY-3156 for the backport.

        Closing this one as won't fix.


          People

          • Assignee:
            Unassigned
            Reporter:
            Ole Solberg
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development