Derby
  1. Derby
  2. DERBY-2035

Setting the database class path takes effect for the current connection but not others until a database reboot.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Incomplete
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: None
    • Component/s: SQL
    • Labels:
      None

      Description

      After setting the derby.database.classpath as a database property the current connection sees its effects, such as being able to load classes from the jar added into the class path. However a newly opened connection does not see its effect. Shutting down and re-booting the database makes the change visible to all.

      The new test lang.DatabaseClassLoadingTest will have code that shows this bug commented with this bug number.

        Activity

        Knut Anders Hatlen added a comment -

        Triaged for 10.5.2.

        I'm not able to reproduce this issue following the steps described here. I also tried removing the workaround from lang.DatabaseClassLoadingTest, but the test passed even without it. Marking the issue as incomplete until we have a reproducible test case.


          People

          • Assignee:
            Unassigned
            Reporter:
            Daniel John Debrunner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development