Derby
  1. Derby
  2. DERBY-1914

test lang/wisconsin gives garbage output on zOS.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.2.1.6, 10.2.2.0, 10.3.1.4
    • Fix Version/s: 10.9.2.2, 10.10.1.1
    • Component/s: Test
    • Environment:
    • Urgency:
      Normal

      Description

      When running the test lang/wisconsin.java on zOS the output in the .tmp file shows non-native characters.
      However, this is most likely a test/test harness specific problem, for if one executes the simple statistics gathering commands through ij, there is no problem. Note that other tests do produce readable (native) output.

      It's impossible to tell if there is any actual problem this way.

      1. wisconsinOutputOnZos.zip
        204 kB
        Kathey Marsden
      2. wisconsinOutputAfterAsciiFtp.zip
        204 kB
        Kathey Marsden
      3. wisconsin_diff.txt
        3 kB
        Kathey Marsden
      4. derby-1914_diff.txt
        3 kB
        Kathey Marsden

        Activity

        Myrna van Lunteren created issue -
        Mike Matrigali made changes -
        Field Original Value New Value
        Component/s Regression Test Failure [ 12310664 ]
        Dag H. Wanvik made changes -
        Derby Categories [Regression Test Failure]
        Dag H. Wanvik made changes -
        Component/s Regression Test Failure [ 12310664 ]
        Dag H. Wanvik made changes -
        Component/s Test [ 11413 ]
        Dag H. Wanvik made changes -
        Issue Type Test [ 6 ] Bug [ 1 ]
        Kathey Marsden added a comment -

        I still see this in release testing for 10.5.2.0 on z/OS with
        java version "1.6.0"
        Java(TM) SE Runtime Environment (build pmz3160sr4-20090219_01(SR4))
        IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 z/OS s390-31 jvmmz3160-2009
        J9VM - 20090215_029883_bHdSMr
        JIT - r9_20090213_2028
        GC - 20090213_AA)
        JCL - 20090218_01

        Kathey Marsden added a comment -

        Attached is the output for wisconsin for this failure. I wanted to see if it was the same thing or something different than DERBY-4641. I think it is indeed different as for this one the input to ij seems to be garbled instead of the output from runtime statistics as the last line if wisconsin.tmp is:
        ERROR 42X02: Lexical error at line 1, column 1. Encountered: "`" (96), after : "".
        ij>

        Kathey Marsden made changes -
        Attachment wisconsinOutputAfterAsciiFtp.zip [ 12443615 ]
        Attachment wisconsinOutputOnZos.zip [ 12443616 ]
        Kathey Marsden made changes -
        Environment ibm 15 jvm on z/OS (aka z-series, or OS/390) ibm 15 jvm on z/OS (aka z-series, or OS/390)

        also
        java version "1.6.0"
        Java(TM) SE Runtime Environment (build pmz3160sr5-20090604_01(SR5))
        IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 z/OS s390-31 jvmmz3160sr5-20090519_3
        5743 (JIT enabled, AOT enabled)
        J9VM - 20090519_035743_bHdSMr
        JIT - r9_20090518_2017
        GC - 20090417_AA)
        JCL - 20090529_01

        (output attached)

        Myrna van Lunteren made changes -
        Labels derby_triage10_8
        Urgency Normal
        Kathey Marsden made changes -
        Assignee Kathey Marsden [ kmarsden ]
        Kathey Marsden added a comment -

        wisconsin seems to be a hybrid test. Half java, half script. The reason for this was to add logic to skip compress for J2ME.
        I don't at least at this moment see where we actually do skip it and am having a bit of trouble with weme to try it out.

        The attached preliminary patch fixes the encoding problem in the old harness by having the test read from the resource rather than the file so it has a known encoding. I will look and see if I can pull it into Junit at least as a JavaHarnessTest.

        Kathey Marsden made changes -
        Attachment derby-1914_diff.txt [ 12533435 ]
        Kathey Marsden added a comment -

        Bringing wisconsin into LangHarnessJavaTest runs now using the resources instead of files but fails because of lack of support for the sed filtering files, e.g. wisconsin_sed.properties.

        I don't really have time right now to convert the whole test Using RuntimeStatisticsParser.
        Is it worthwhile to bring the sed properties processing into CanonTestCase or would it be better to just leave this one in derbyall until someone gets to converting it? There are actually 21 tests with xxx_sed.properties files. At the slow rate we are getting tests converted, it might be a worthwhile incremental move but would bring some of the arcane logic of the harness into our JUnit tests.

        Thoughts?

        Kathey Marsden added a comment -

        actually, I think not. I realize this would mean bringing jakarta into the set of jars required to run JUnit tests, so I think not a good idea.

        Kathey Marsden added a comment -

        Here is an updated patch for this issue which removes use of BaseTestCase in wisconsin.java.

        Kathey Marsden made changes -
        Attachment wisconsin_diff.txt [ 12534024 ]
        Kathey Marsden made changes -
        Bug behavior facts Regression Test Failure [ 10369 ]
        Issue & fix info Patch Available [ 10102 ]
        Myrna van Lunteren added a comment -

        Patch was committed to trunk with revision 1355569 (so before 10.10 branch) and 10.9 with revision 1373148.

        Myrna van Lunteren added a comment -

        This did not occur with 10.10.1.1., Closing.

        Myrna van Lunteren made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Issue & fix info Patch Available [ 10102 ]
        Fix Version/s 10.10.1.1 [ 12321550 ]
        Fix Version/s 10.9.2.2 [ 12324102 ]
        Resolution Fixed [ 1 ]
        Rick Hillegas made changes -
        Fix Version/s 10.9.1.1 [ 12323562 ]
        Fix Version/s 10.9.2.2 [ 12324102 ]
        Gavin made changes -
        Workflow jira [ 12386022 ] Default workflow, editable Closed status [ 12802369 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        2374d 19h 38m 1 Myrna van Lunteren 03/Apr/13 22:42

          People

          • Assignee:
            Kathey Marsden
            Reporter:
            Myrna van Lunteren
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development