Derby
  1. Derby
  2. DERBY-1883

I18N tests fail on Linux/JVM 1.4.2 when derbyclient.jar is the first element of the classpath

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.2.1.6, 10.3.1.4
    • Fix Version/s: 10.2.2.0, 10.3.1.4
    • Component/s: Test
    • Labels:
      None
    • Environment:
      Linux, Sun J2SE 1.4.2, CLASSPATH=derbyclient.jar:....
    • Bug behavior facts:
      Regression Test Failure

      Description

      i18n/urlLocale.sql, i18n/messageLocale.sql and i18n/iepnegativetests_ES.sql fail on Linux when running Sun J2SE 1.4.2 and derbyclient.jar is the first element of the classpath. See http://www.multinet.no/~solberg/public/Apache/10.2.1.3_RC/jvm1.4/testlog/linN-1/441574-derbyall_diff.txt. The problem is not seen on Solaris or FreeBSD, or when running with 1.5/1.6 JVM.

      When derbyclient.jar is moved to a position after derby.jar in the classpath, the tests run successfully.

      1. 1883.diff
        0.8 kB
        Knut Anders Hatlen

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        2d 20h 41m 1 Knut Anders Hatlen 26/Sep/06 07:54
        Closed Closed Reopened Reopened
        20d 3h 30m 1 Knut Anders Hatlen 16/Oct/06 11:24
        Reopened Reopened Closed Closed
        1m 33s 1 Knut Anders Hatlen 16/Oct/06 11:26
        Gavin made changes -
        Workflow jira [ 12384344 ] Default workflow, editable Closed status [ 12798276 ]
        Dag H. Wanvik made changes -
        Component/s Test [ 11413 ]
        Dag H. Wanvik made changes -
        Component/s Regression Test Failure [ 12310664 ]
        Dag H. Wanvik made changes -
        Derby Categories [Regression Test Failure]
        Knut Anders Hatlen made changes -
        Status Reopened [ 4 ] Closed [ 6 ]
        Fix Version/s 10.2.1.8 [ 12312096 ]
        Resolution Fixed [ 1 ]
        Knut Anders Hatlen added a comment -

        Committed to 10.2 with revision 464441.

        Knut Anders Hatlen made changes -
        Status Closed [ 6 ] Reopened [ 4 ]
        Resolution Fixed [ 1 ]
        Knut Anders Hatlen made changes -
        Fix Version/s 10.3.0.0 [ 12310800 ]
        Assignee Knut Anders Hatlen [ knutanders ]
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Knut Anders Hatlen added a comment -

        Committed revision 449930.

        Knut Anders Hatlen made changes -
        Field Original Value New Value
        Attachment 1883.diff [ 12341458 ]
        Knut Anders Hatlen added a comment -

        Seems like a security manager issue. At least, the attached patch (1883.diff), which grants derbyclient.jar permission to read derby.* properties, makes the tests run cleanly. I believe the problems are caused by the LocalizedResource class which is part of both derby.jar and derbyclient.jar. LocalizedResource needs permission to read derby.ui.codeset and derby.ui.locale.

        Knut Anders Hatlen created issue -

          People

          • Assignee:
            Knut Anders Hatlen
            Reporter:
            Knut Anders Hatlen
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development