Derby
  1. Derby
  2. DERBY-1870

stress/stress.multi: Cannot issue rollback in a nested connection when there is a pending operation in the parent connection.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
    • Bug behavior facts:
      Regression Test Failure

      Description

      I am not sure if this is a test- or a product-bug. I think I have seen ti before, but could not find any JIRA-issue resembling this failure.

      From derbyall/multi/stress.log:

      .....
      Tester2: SELECT2 Tue Sep 12 22:43:24 MEST 2006
      Tester3: SELECT1 Tue Sep 12 22:43:24 MEST 2006
      Tester8: roll Tue Sep 12 22:43:24 MEST 2006
      Tester5: TERMINATING due to unexpected error:
      FatalException: X0Y67: Cannot issue rollback in a nested connection when there is a pending operation in the parent connection.
      Tester9: TERMINATING due to unexpected error:
      FatalException: X0Y67: Cannot issue rollback in a nested connection when there is a pending operation in the parent connection.
      Tester4: SELECT2 Tue Sep 12 22:43:26 MEST 2006
      Tester8: TERMINATING due to unexpected error:
      FatalException: 08003: No current connection.
      Tester1: stopping on request after 359 iterations
      Tester2: stopping on request after 372 iterations
      Tester4: stopping on request after 420 iterations
      Tester3: stopping on request after 389 iterations
      Tester7: stopping on request after 407 iterations
      Tester6: stopping on request after 329 iterations
      Tester10: TERMINATING due to unexpected error:
      FatalException: XJ001: Java exception: ': java.lang.NullPointerException'.

      test ran 169196 ms
      total memory is 32702464
      free memory is 13274472
      Deleting Tester1.out(/export/home/tmp/jagtmp/autoderbyN_regression/derbyall_1/log/derbyall/multi)
      Deleting Tester2.out(/export/home/tmp/jagtmp/autoderbyN_regression/derbyall_1/log/derbyall/multi)
      Deleting Tester3.out(/export/home/tmp/jagtmp/autoderbyN_regression/derbyall_1/log/derbyall/multi)
      Deleting Tester4.out(/export/home/tmp/jagtmp/autoderbyN_regression/derbyall_1/log/derbyall/multi)
      Tester5 failed.
      Deleting Tester6.out(/export/home/tmp/jagtmp/autoderbyN_regression/derbyall_1/log/derbyall/multi)
      Deleting Tester7.out(/export/home/tmp/jagtmp/autoderbyN_regression/derbyall_1/log/derbyall/multi)
      Tester8 failed.
      Tester9 failed.
      Tester10 failed.

      1. multi.zip
        271 kB
        Ole Solberg

        Activity

        Mike Matrigali added a comment -

        can you include the derby.log for this run? If at all possible it is best to either zip up the entire stress dir and it's children
        or if it is available publicly provide a pointer to where it is. Sometimes there is info in derby.log, sometimes in the individual
        test logs, sometimes being able to access the db is interesting.

        Kathey Marsden added a comment -

        Closing CNR. We didn't get any information on the issue and I don't think it has occurred since in stress.multi or its replacement StressMultiTest.


          People

          • Assignee:
            Unassigned
            Reporter:
            Henri van de Scheur
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development