Derby
  1. Derby
  2. DERBY-1815

In admin guide examples to start network server on windows with .bat scripts, $DERYBY_INSTALL Is used , I think it should be %DERBY_INSTALL%

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.3.1.4
    • Component/s: Documentation
    • Labels:
      None
    • Environment:
      Windows ...

      Description

      In the Admin Guide . Starting the Network Server (
      http://db.apache.org/derby/docs/dev/adminguide/tadmincbdjhhfd.html ) . I think following is not right.

      $DERBY_INSTALL\frameworks\NetworkServer\bin\startNetworkserver.bat

      it should be :

      %DERBY_INSTALL%\frameworks\NetworkServer\bin\startNetworkserver.bat

      — Although it is clear from the descripton from what $DERBY_INSATLL means there. Some of the users will copy/paste commands and will not be very happy , if it does not work off-hand.

        Activity

        Suresh Thalamati created issue -
        John H. Embretsen added a comment -

        I think the problem is that the admin guide is not clear enough about whether $DERBY_INSTALL should be an environment variable or not, and that this may create the situation Suresh describes with copy/paste. The text does not say that $DERBY_INSTALL is an environment variable, but it says:

        "(...) $DERBY_INSTALL is the directory where you installed Derby."

        Thus, based on the admin guide alone, $DERBY_INSTALL should (in my opinion) not be interpreted as an environment variable, meaning that all users (both Windows and Unix) must replace occurrences of $DERBY_INSTALL with the path to the directory in which they installed Derby. Of course, all users are free to create such an environment variable, and since $DERBY_INSTALL looks exactly like a Unix environment variable, I understand that this may cause some confusion.

        In other words, I think simply changing $DERBY_INSTALL to %DERBY_INSTALL% in the example provided is not a good solution. If it is changed, some additional wording is needed to explain that it must be an environment variable if copied/pasted directly.

        Jean T. Anderson added a comment -

        Maybe change to DERBY_HOME instead of DERBY_INSTALL to be consistent with DERBY-1032 ?

        Kim Haase added a comment -

        The change from DERBY_INSTALL to DERBY_HOME was made in src/adminguide/tadmincbdjhhfd.dita as part of another fix, so this bug can be closed.

        Myrna van Lunteren added a comment -

        Looks like that was fixed with revision 505092, for DERBY-1662.

        Myrna van Lunteren made changes -
        Field Original Value New Value
        Assignee Kim Haase [ chaase3 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 10.3.0.0 [ 12310800 ]
        Status Open [ 1 ] Closed [ 6 ]
        Kim Haase added a comment -

        Thanks! I'm glad you were able to figure out which fix made that change – I had lost track.

        Gavin made changes -
        Workflow jira [ 12383030 ] Default workflow, editable Closed status [ 12798399 ]

          People

          • Assignee:
            Kim Haase
            Reporter:
            Suresh Thalamati
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development