Derby
  1. Derby
  2. DERBY-1750

encryption/stress.multi fails with FatalException: XJ001: Java exception: ': java.lang.AbstractMethodError'. on Linux and Windows XP

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
    • Urgency:
      Normal
    • Bug behavior facts:
      Regression Test Failure

      Description

      encryption/encryption.fail:stress/stress.multi

                      • Diff file encryption/multi/stress.diff
          • Start: stress jdk1.6.0-rc encryption:multi 2006-08-14 13:33:14 ***
            6 del
            < TEST CASE SUMMARY: normal termination
            7 del
            < ...running last checks via final.sql
            7 add
            > TEST CASE SUMMARY: abnormal termination due to error(s) – see test log (./stress/stress.log) for details
            Test Failed.
          • End: stress jdk1.6.0-rc encryption:multi 2006-08-14 13:39:02 ***
            ------------------------------------------------------

      From stress.log:
      .....
      Tester6: SELECT1 Mon Aug 14 13:38:25 CEST 2006
      Tester4: insert Mon Aug 14 13:38:25 CEST 2006
      Tester10: TERMINATING due to unexpected error:
      FatalException: XJ001: Java exception: ': java.lang.AbstractMethodError'.
      Tester1: update Mon Aug 14 13:38:25 CEST 2006
      Tester1: roll Mon Aug 14 13:38:25 CEST 2006
      .....
      Deleting Tester9.out(/export/home/tmp/jagtmp/autoderbyN_regression/encryption_6/log/encryption/multi)
      Tester10 failed.

        Activity

        Knut Anders Hatlen added a comment -

        I don't know if it helps (no stack trace), but here's the last part of Tester10.log:

        835 rows selected
        ij> disconnect;
        ij> -------------createz.sql----------------
        ij version 10.2
        CONNECTION0* - jdbc:derby:mydb

        • = current connection
          ij> autocommit off;
          ij> create table z (x int);
          0 rows inserted/updated/deleted
          ij> insert into z values (1);
          1 row inserted/updated/deleted
          ij> insert into z values (1);
          1 row inserted/updated/deleted
          ij> insert into z values (1);
          1 row inserted/updated/deleted
          ij> insert into z values (1);
          ERROR 38000: The exception 'java.lang.AbstractMethodError' was thrown while evaluating an expression.
          ERROR XJ001: Java exception: ': java.lang.AbstractMethodError'.
        Knut Anders Hatlen added a comment -

        I haven't seen reports about stress.multi failing with an
        AbstractMethodError since this issue was filed. Since it happened on a
        preview of JDK 6 (1.6.0-rc-b95) I'd say it's probably a problem in the
        JDK, and I suggest we close this issue as "Cannot Reproduce".

        Knut Anders Hatlen added a comment -

        For the record, I got hold of a copy of build 95 of the JDK for Linux,
        built Derby from revision 430903 on the 10.2 branch (the revision this
        bug was filed against), and ran the encryption:multi suite 100 times
        without seeing the error.

        Henri van de Scheur added a comment -

        I agree with Knut Anders. If this should happen again, the issue can be reopened.


          People

          • Assignee:
            Unassigned
            Reporter:
            Henri van de Scheur
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development