Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.4.1.3
    • Component/s: SQL
    • Labels:
      None

      Description

      The implementations of CatalogRowFactory.buildColumnList() can be simplified in a number of ways:
      1) precision & scale are always passed in as zero and can be removed
      2) adding static factory methods to SystemColumnImpl would ease the building of the arrays by not requiring the additional redundant arguments the constructor call forces today, e.g. max length i snot required to create an INTEGER column.
      3) The column's position is not required to be stored in the SytstemColumn class, it's defined by the position in the array

      4) arrays can be built using
      new SystemColumn[]

      { ... }

      syntax instead of the existing
      columnList[0] = ...
      columnList[1] = ...

      or

      columnList[index++] = ...
      columnList[index++] = ...

        Activity

        Daniel John Debrunner added a comment -

        5) No requirement to convert the case for column names, these classes are for Derby's implementation of its system catalogs, and Derby uses a upper case for system identifiers.

        Rick Hillegas added a comment -

        Original patches DERBY-1734 (433434, 433349) ported to 10.2 branch at subversion revision 436875.

        Rick Hillegas added a comment -

        Ported DERBY-1734 (434083) to 10.2 at subversion revision 436921.

        Daniel John Debrunner added a comment -

        All CatalogRowFactory.buildColumnList() methods use the new style mechanism.

        Ole Solberg added a comment -

        2007-11-20 nightlies: 10.3 regression tests fails in lang/CompressTable.sql.

        Probably caused by r596490 which includes r564792:

        We saw the same with r564792 on trunk. This was fixed by
        r566353 | djd | 2007-08-15 23:45:33 +0200 (Wed, 15 Aug 2007) | 1 line - Fix compressTable master file.

        See e.g. http://dbtg.thresher.com/derby/test/10.3Branch/jvm1.6/testing/Limited/testSummary-596747.html
        or http://dbtg.thresher.com/derby/test/stats_today.html as of 2007-11-21 (the "-5001" entry).


          People

          • Assignee:
            Daniel John Debrunner
            Reporter:
            Daniel John Debrunner
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development