Derby
  1. Derby
  2. DERBY-1695

testSecMec.java fails with JCC 2.6 and JCC 2.8

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: 10.2.1.6, 10.3.1.4
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      After the checkin for DERBY-528 testSecMec fails with JCC 2.6 and 2.8. My hope was to just wait until the masters were normalized with the conversion of this test to Junit, but I think that work has been deferred for a bit so I will look at the current test.

      I have had a problem with this test on my machine for sometime with DERBY-1114 like symptoms with all jvms and even with derbyclient. I need to investigate that or run on another machine to resolve this issue.

      1. Derby1695.stat.txt
        0.6 kB
        Sunitha Kambhampati
      2. derby1695.diff.txt
        130 kB
        Sunitha Kambhampati

        Issue Links

          Activity

          Sunitha Kambhampati added a comment -

          Verified that the test passes now. with jcc2.6 and jcc2.8, so closing this issue.

          Rick Hillegas added a comment -

          Merged DERBY-1695 / DERBY-528 (436672) to 10.2 at subversion revision 436936.

          Sunitha Kambhampati added a comment -

          Thanks Andrew for the commit. Just wanted to note that this change also needs to be merged to 10.2 branch.

          Andrew McIntyre added a comment -

          Committed Sunitha's patch with updated masters for JCC 2.6 and JCC 2.8 to trunk with revision 436672.

          Sunitha Kambhampati added a comment -

          Updated the master files for jcc2.6 and jcc2.8, the diffs were being caused because of derby-528 checkin.

          – Ran the testSecMec test with jcc2.4, jcc2.6 and jcc2.8 on ibm131/ibm142/ibm15, jdk131/jdk142/jdk15 ok.

          Francois, it would be great if you could review these changes as they are related to the derby-528.

          If this looks ok, can someone please commit this.

          Thanks.

          Francois Orsini added a comment -

          Thanks for the update kathey - what do you think the next steps of action should be for this issue? It seems like it worked at some point as you mentioned but it is now failing consistenly...

          I can try and run them but I'd to know where I can download JCC 2.6 and 2.8 - I only found JCC 2.4 when I searched for JCC, even recently...I'll look into them more as well...

          Kathey Marsden added a comment -

          Well I did see this pass once with the upped timeout, but now seem to reliably get:
          > FAIL: Server failed to respond to ping - ending test

          with firewall turned on and ping time set to 120.

          I am sorry I won't be able to update the masters for this issue.

          Kathey


            People

            • Assignee:
              Sunitha Kambhampati
              Reporter:
              Kathey Marsden
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development