Derby
  1. Derby
  2. DERBY-1691

jdbcapi/blobclob4BLOB.java fails under DerbyNet framework with JCC 2.6

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: 10.2.1.6
    • Component/s: Test
    • Labels:
      None
    • Environment:
      Linux 2.6.9-5.ELsmp Sun jdk 1.5.0_07-b03
    • Bug behavior facts:
      Regression Test Failure

      Description

      With JCC 2.6, the jdbcapi/blobclob4BLOB.java fails. The diff did not show anything alarming, so I am guessing it
      may be a master update. The test passed fine with DerbyClient

          • Start: blobclob4BLOB jdk1.5.0_06 DerbyNet derbynetmats:jdbcapi 2006-08-11 23:29:48 ***
            466a467,474
            > EXPECTED SQLSTATE(22018): Invalid character string format for type INTEGER.
            > end clobTest54
            > START: clobTest6
            > EXPECTED SQLSTATE(null): Invalid position 0 or length 5
            > EXPECTED SQLSTATE(null): Invalid position 1 or length -76
            > EXPECTED SQLSTATE(null): Invalid position 1 or length -1
            > EXPECTED SQLSTATE(null): Invalid position 0 or length 0
            > FAIL – unexpected exception:java.lang.StringIndexOutOfBoundsException: String index out of range: -1
            468,475d475
            < EXPECTED SQLSTATE(22018): Invalid character string format for type INTEGER.
            < end clobTest54
            < START: clobTest6
            < EXPECTED SQLSTATE(null): Invalid position 0 or length 5
            < EXPECTED SQLSTATE(null): Invalid position 1 or length -76
            < EXPECTED SQLSTATE(null): Invalid position 1 or length -1
            < EXPECTED SQLSTATE(null): Invalid position 0 or length 0
            < FAIL – unexpected exception:java.lang.StringIndexOutOfBoundsException: String index out of range: -1
            775a776,782
            > blobTest54 finished
            > START: blobTest6
            > EXPECTED SQLSTATE(null): Invalid position 0 or length 5
            > EXPECTED SQLSTATE(null): Invalid position 1 or length -76
            > EXPECTED SQLSTATE(null): Invalid position 1 or length -1
            > EXPECTED SQLSTATE(null): Invalid position 0 or length 0
            > FAIL – unexpected exception:java.lang.NegativeArraySizeException
            777,783d783
            < blobTest54 finished
            < START: blobTest6
            < EXPECTED SQLSTATE(null): Invalid position 0 or length 5
            < EXPECTED SQLSTATE(null): Invalid position 1 or length -76
            < EXPECTED SQLSTATE(null): Invalid position 1 or length -1
            < EXPECTED SQLSTATE(null): Invalid position 0 or length 0
            < FAIL – unexpected exception:java.lang.NegativeArraySizeException
            789 del
            < com.ibm.db2.jcc.c.SqlException: Operation 'CREATE TRIGGER' cannot be performed on object 'TESTBLOB' because there is an open ResultSet dependent on that object.
            789a789
            > com.ibm.db2.jcc.a.SqlException: Operation 'CREATE TRIGGER' cannot be performed on object 'TESTBLOB' because there is an open ResultSet dependent on that object.
            Test Failed.
          • End: blobclob4BLOB jdk1.5.0_06 DerbyNet derbynetmats:jdbcapi 2006-08-11 23:30:46 ***
      1. derby-1651.diff
        85 kB
        Øystein Grøvlen

        Issue Links

          Activity

          Andrew McIntyre added a comment -

          This issue has been resolved for over a year with no further movement. Closing.

          Andreas Korneliussen added a comment -

          Committed revision 442199.

          Andreas Korneliussen added a comment -

          Patch looks good. Got one conflict in DerbyNet.exclude, which I resolved. I will run some tests and commit.

          Øystein Grøvlen added a comment -

          derby-1651.diff fixes the problem of merged output by making sure all
          stack traces are written to stdout and not stderr. It also removes
          the version-specific and jvm-specific canons that failed to solve this
          problem, and re-enables the test for the DerbyNet framework. In my
          environment and for all frameworks, the test now runs without
          failures.

          Changed files:
          M java/testing/org/apache/derbyTesting/functionTests/tests/jdbcapi/blobclob4BLOB.java
          D java/testing/org/apache/derbyTesting/functionTests/master/DerbyNet/ver2.6/blobclob4BLOB.out
          D java/testing/org/apache/derbyTesting/functionTests/master/DerbyNet/jdk15/blobclob4BLOB.out
          M java/testing/org/apache/derbyTesting/functionTests/suites/DerbyNet.exclude

          Øystein Grøvlen added a comment -

          The problem here is that output to stdout and stderr gets merge in
          different ways in different test runs. This problem can not be solved
          by just updating the master files! I plan to fix this by making sure
          all output goes to stdout.

          Rick Hillegas added a comment -

          Ported DERBY-1691 (434245) to 10.2 branch at subversion revision 436921.

          Andrew McIntyre added a comment -

          blobclob4BLOB excluded from running against JCC with revision 434245.

          John H. Embretsen added a comment -

          With revision 433790, Andrew McIntyre tried to fix this issue by adding and modifying master files:

          ------------------------------------------------------------------------
          r433790 | fuzzylogic | 2006-08-23 00:54:32 +0200 (Wed, 23 Aug 2006) | 3 lines

          Add some JCC and JDK version specific masters in the hopes of fixing the
          blobclob4BLOB test.

          ------------------------------------------------------------------------

          Changed files:

          trunk/java/testing/org/apache/derbyTesting/functionTests/master/DerbyNet/blobclob4BLOB.out (modified , text changed)
          trunk/java/testing/org/apache/derbyTesting/functionTests/master/DerbyNet/jdk15/blobclob4BLOB.out (added)
          trunk/java/testing/org/apache/derbyTesting/functionTests/master/DerbyNet/ver2.6/blobclob4BLOB.out (added)

          http://www.nabble.com/Re%3A-svn-commit%3A-r433790---in--db-derby-code-trunk-java-testing-org-apache-derbyTesting-functionTests-master-DerbyNet%3A-blobclob4BLOB.out-jdk15-blobclob4BLOB.out-ver2.6-blobclob4BLOB.out-t2149648.html

          Unfortunately, this effort was not successful:

          http://www.nabble.com/Regression-Test-Failure%21---TinderBox_Derby-433825---Sun-DBTG-t2150345.html

          This test should probably be excluded from the DerbyNet framework until we have a working solution.

          Øystein Grøvlen added a comment -

          David, the test is now failing with the same diff as two fixes ago. It seems like you have been toggling back and forth between two different master files that both creates problems. From what I can see from the diffs, the problem is that the sequence of output is not always the same. This can not be solved by switching from one sequence to another in the master file. One will have to fix the test so that the output sequence is deterministic.

          David Van Couvering added a comment -

          Ok, I downloaded JCC 1.6 and tried again. I filtered out the strange obfuscated class path diffs using a sed file. It now passes with
          JCC 1.6. I don't feel obligated to get this to work on other versions of JCC.

          Checked in revision 432432. I'll check the next test run and see if this solves the problem.

          David Van Couvering added a comment -

          Sigh... I'll look at this. Really, it passed on my platform. Craig, this is the last time I'll commit a patch for you

          Mike Matrigali added a comment -

          I am also seeing the following diffs in my nightly runs against sun jdk1.4.2, on xp. reopening as it seems like this issue was not fully fixed rather than a new issue. If I am wrong, let me know and I can open a new issue:

              • Start: blobclob4BLOB jdk1.4.2_07 DerbyNet derbynetmats:jdbcapi 2006-08-16 20
                :05:11 ***
                466a467
                > java.lang.StringIndexOutOfBoundsException: String index out of range: -1
                476d476
                < java.lang.StringIndexOutOfBoundsException: String index out of range: -1
                775a776
                > java.lang.NegativeArraySizeException
                784d784
                < java.lang.NegativeArraySizeException
                Test Failed.
              • End: blobclob4BLOB jdk1.4.2_07 DerbyNet derbynetmats:jdbcapi 2006-08-16 20
                :07:29 ***
          John H. Embretsen added a comment -

          The first diff mentioned in this issue started occurring in the daily Sun DBTG test results on August 11 (SVN 430835), and are most likely caused by the fix for DERBY-1516, SVN 430825. Linking the issues.

          John H. Embretsen added a comment -

          This test is still failing in the Tinderbox runs, but because of the master file update in SVN 431663, the diff is different:

                          • Diff file derbyall/derbynetmats/DerbyNet/jdbcapi/blobclob4BLOB.diff
              • Start: blobclob4BLOB jdk1.5.0_04 DerbyNet derbynetmats:jdbcapi 2006-08-17 00:43:40 ***
                474a475
                > java.lang.StringIndexOutOfBoundsException: String index out of range: -1
                476d476
                < java.lang.StringIndexOutOfBoundsException: String index out of range: -1
                782a783
                > java.lang.NegativeArraySizeException
                784d784
                < java.lang.NegativeArraySizeException
                Test Failed.
              • End: blobclob4BLOB jdk1.5.0_04 DerbyNet derbynetmats:jdbcapi 2006-08-17 00:44:12 ***

          I think simply changing the master file may not be the right solution in this case, but I have not looked at it enough to suggest an alternative yet.

          Craig L Russell added a comment -

          There is a tiny difference in the message text for:

          com.ibm.db2.jcc.c.SqlException
          com.ibm.db2.jcc.a.SqlException

          Is the difference something needs to be explained?

          Craig

          David Van Couvering added a comment -

          I've committed revision 431663, hopefully this should make the diff go away.

          David Van Couvering added a comment -

          The problem is I don't get this diff on my machine. I am not even sure that the differences are.-- if you look at them, the text looks exactly the same. Guidance much appreciated.

          Rajesh Kartha added a comment -

          The failure was seen with the build - 10.2.1.0 beta - (430903), the beta candidate posted)


            People

            • Assignee:
              Øystein Grøvlen
              Reporter:
              Rajesh Kartha
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development