Derby
  1. Derby
  2. DERBY-1666

Show Views and Show Synonyms has confusing column names in results

    Details

    • Type: Improvement Improvement
    • Status: Open
    • Priority: Minor Minor
    • Resolution: Unresolved
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: None
    • Component/s: Tools
    • Labels:
      None
    • Urgency:
      Normal
    • Issue & fix info:
      Known fix, Newcomer, Repro attached

      Description

      When you run SHOW VIEWS and SHOW SYNONYMS, the column names are confusing. They use TABLE_SCHEM and TABLE_NAME instead of VIEW_SCHEM/VIEW_NAME and SYNONYM_SCHEM/SYONYM_NAME

      === Examples ===

      ij> show views;
      TABLE_SCHEM |TABLE_NAME |REMARKS
      ------------------------------------------------------------------------
      APP |AA_FLIGHTS |

      ij> show synonyms;
      TABLE_SCHEM |TABLE_NAME |REMARKS
      ------------------------------------------------------------------------
      APP |COLUMNS |
      APP |TRIGGERS |

        Activity

        Hide
        Andrew McIntyre added a comment -

        These are names of the columns in the result set returned from DatabaseMetaData.getTables. Having just read through all of this code, the fix could be to pass the desired column names to ijResultSetResult from the parser in ij.showTables and then JDBCDisplayUtil could check for column name overrides when displaying an ijResultSetResult.

        Show
        Andrew McIntyre added a comment - These are names of the columns in the result set returned from DatabaseMetaData.getTables. Having just read through all of this code, the fix could be to pass the desired column names to ijResultSetResult from the parser in ij.showTables and then JDBCDisplayUtil could check for column name overrides when displaying an ijResultSetResult.
        Hide
        Jazarine Jamal added a comment -

        i JUST STARTED WORKING ON THE BUG..

        Show
        Jazarine Jamal added a comment - i JUST STARTED WORKING ON THE BUG..
        Hide
        Kathey Marsden added a comment -

        Unassigning due to inactivity. Please reassign yourself if you would like to work on this bug.

        Show
        Kathey Marsden added a comment - Unassigning due to inactivity. Please reassign yourself if you would like to work on this bug.
        Hide
        Knut Anders Hatlen added a comment -

        Triaged for 10.5.2. Reclassifying from bug to improvement.

        Show
        Knut Anders Hatlen added a comment - Triaged for 10.5.2. Reclassifying from bug to improvement.

          People

          • Assignee:
            Unassigned
            Reporter:
            David Van Couvering
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:

              Development