Derby
  1. Derby
  2. DERBY-1649

lang/wisconsin.java fails with different cursor names

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: 10.2.1.6
    • Component/s: Test
    • Labels:
      None
    • Environment:
    • Urgency:
      Normal
    • Bug behavior facts:
      Regression Test Failure

      Description

          • Start: wisconsin jdk1.5.0_06 DerbyNetClient derbynetmats:derbynetmats 2006-08-04 00:47:14 ***
            41 del
            < C
            41a41
            > SQL_CURLH000C7
            102 del
            ....
            -----------------------------
            This diff first started occurring on Aug 3 nightly run.change between (428211)
            and 10.2.0.5 alpha - (428586)

      My first guess is, this may be related to this checkin
      ------------------------------------------------------------------------
      r428252 | djd | 2006-08-02 22:58:44 -0700 (Wed, 02 Aug 2006) | 3 lines

      DERBY-1609 (partial) Change the lang/wisconsin.java test to use the new ij.runScript method
      rather than its previous use of the utilMain.go method. Change the sed commands because the
      cursor names are different in the output due to the use of a connection in a different state.
      ------------------------------------------------------------------------

      1. derby-1649-sed_v1.diff
        2 kB
        John H. Embretsen

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Resolved Resolved
        4d 4h 14m 1 Andrew McIntyre 09/Aug/06 05:38
        Resolved Resolved Closed Closed
        8d 12h 44m 1 Sunitha Kambhampati 17/Aug/06 18:23
        Gavin made changes -
        Workflow jira [ 12379576 ] Default workflow, editable Closed status [ 12798966 ]
        Dag H. Wanvik made changes -
        Component/s Regression Test Failure [ 12310664 ]
        Dag H. Wanvik made changes -
        Derby Categories [Regression Test Failure]
        Sunitha Kambhampati made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Sunitha Kambhampati added a comment -

        Thanks John for fixing this issue. This test passes OK now. So closing this issue.

        John H. Embretsen added a comment -

        I have not seen this failure in any tests since this issue was resolved. Sunitha, can you check the results in your environment and close the issue if things look all right to you? Thanks!

        Andrew McIntyre made changes -
        Derby Info [Patch Available]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Andrew McIntyre added a comment -

        Sed problem with cursor names fixed in trunk with revision 429677. Marking resolved.

        Rick Hillegas added a comment -

        Thanks for this improvement, John! Committed at subversion revision 429677.

        John H. Embretsen made changes -
        Derby Info [Patch Available]
        John H. Embretsen made changes -
        Attachment derby-1649-sed_v1.diff [ 12338384 ]
        John H. Embretsen added a comment -

        Attatching patch 'derby-1649-sed_v1.diff', which modifies the following file:

        M java/testing/org/apache/derbyTesting/functionTests/tests/lang/wisconsin_sed.properties

        The problem was that the last digit in the cursor name represented by

        SQL_CURLH000C6

        in the wisconsin_sed.properties file is varying between platforms (frameworks, jvm versions, OS,etc.). I have seen both 2, 5, 6 and 7 as the last digit when running this test, or in diffs from the daily/nightly regression tests.

        With revision 428252, the last digit to be accepted for filtering by the test harness was changed from 1 to 6.

        My patch allows cursor names with last digits varying from 1 through 9 to be filtered out:

        SQL_CURLH000C[1-9];C

        I don't know much about cursor names or which values should not be allowed, if any, so if you feel that this solution is not adequate, feel free to reassign the issue and/or to make informative comments.

        On my desktop, this test failed with wrong cursor name with sun's JVM 1.4.2, but not with 1.5.0 or 1.6.0 (beta). I have tested the patch by running the wisconsin test in those three JVMs in embedded and DerbyNetClient frameworks. Tests were successful.

        Please review/commit this patch.

        Thanks!

        John H. Embretsen made changes -
        Environment ------------------ Java Information ------------------
        Java Version: 1.5.0_06
        Java Vendor: Sun Microsystems Inc.
        Java home: /local1/cloudtst/dev/src/jdk15/jre
        Java classpath: /local1/cloudtst/dev/src/jars/insane/derby.jar:/local1/cloudtst/dev/src/jars/insane/derbytools.jar:/local1/cloudtst/dev/src/jars/insane/derbynet.jar:/local1/cloudtst/dev/src/jars/insane/derbyclient.jar:/local1/cloudtst/dev/src/jars/insane/derbyTesting.jar:/local1/cloudtst/dev/src/jcc/db2jcc.jar:/local1/cloudtst/dev/src/jcc/db2jcc_license_c.jar:/local1/cloudtst/dev/src/jars/insane/derbyTesting.jar:/local1/cloudtst/dev/src/tools/java/jakarta-oro-2.0.8.jar:/local1/cloudtst/dev/src/tools/java/junit.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_de_DE.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_es.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_fr.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_it.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_ja_JP.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_ko_KR.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_pt_BR.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_zh_CN.jar:/local1/cloudtst/dev/src/jars/insane/derbyLocale_zh_TW.jar:/local1/cloudtst/dev/src/jars/insane/derbyrun.jar:
        OS name: Linux
        OS architecture: i386
        OS version: 2.6.5-7.257-bigsmp
        Java user name: cloudtst
        Java user home: /u/cloudtst
        Java user dir: /local1/cloudtst/dev/src/NightlyBuildResults.2006-08-03/jdk15_derbyall
        java.specification.name: Java Platform API Specification
        java.specification.version: 1.5
        --------- Derby Information --------
        JRE - JDBC: J2SE 5.0 - JDBC 3.0
        [/local1/cloudtst/dev/src/jars/insane/derby.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jars/insane/derbytools.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jars/insane/derbynet.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jars/insane/derbyclient.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jcc/db2jcc.jar] 2.6 - (90)
        [/local1/cloudtst/dev/src/jcc/db2jcc_license_c.jar] 2.6 - (90)
        ------------------------------------------------------
        ----------------- Locale Information -----------------
        ------------------ Java Information ------------------
        Java Version: 1.5.0_06
        Java Vendor: Sun Microsystems Inc.
        Java home: /local1/cloudtst/dev/src/jdk15/jre
        Java classpath: [Line-breaks inserted to improve Jira readability]
        /local1/cloudtst/dev/src/jars/insane/derby.jar:
        /local1/cloudtst/dev/src/jars/insane/derbytools.jar:
        /local1/cloudtst/dev/src/jars/insane/derbynet.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyclient.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyTesting.jar:
        /local1/cloudtst/dev/src/jcc/db2jcc.jar:
        /local1/cloudtst/dev/src/jcc/db2jcc_license_c.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyTesting.jar:
        /local1/cloudtst/dev/src/tools/java/jakarta-oro-2.0.8.jar:
        /local1/cloudtst/dev/src/tools/java/junit.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_de_DE.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_es.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_fr.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_it.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_ja_JP.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_ko_KR.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_pt_BR.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_zh_CN.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyLocale_zh_TW.jar:
        /local1/cloudtst/dev/src/jars/insane/derbyrun.jar:
        OS name: Linux
        OS architecture: i386
        OS version: 2.6.5-7.257-bigsmp
        Java user name: cloudtst
        Java user home: /u/cloudtst
        Java user dir: /local1/cloudtst/dev/src/NightlyBuildResults.2006-08-03/jdk15_derbyall
        java.specification.name: Java Platform API Specification
        java.specification.version: 1.5
        --------- Derby Information --------
        JRE - JDBC: J2SE 5.0 - JDBC 3.0
        [/local1/cloudtst/dev/src/jars/insane/derby.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jars/insane/derbytools.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jars/insane/derbynet.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jars/insane/derbyclient.jar] 10.2.0.5 alpha - (428586)
        [/local1/cloudtst/dev/src/jcc/db2jcc.jar] 2.6 - (90)
        [/local1/cloudtst/dev/src/jcc/db2jcc_license_c.jar] 2.6 - (90)
        ------------------------------------------------------
        ----------------- Locale Information -----------------
        John H. Embretsen added a comment -

        Inserting line-breaks in Evironment classpath to improve Jira readability.

        John H. Embretsen made changes -
        Field Original Value New Value
        Assignee John H. Embretsen [ johnemb ]
        Component/s Test [ 11413 ]
        Urgency Normal
        Affects Version/s 10.2.0.0 [ 11187 ]
        John H. Embretsen added a comment -

        I would like to see this fixed before we start evaluating the beta/release candidate(s), since it creates a lot of unnecessary noise that developers and testers have to sift through every time derbyall is run, given certain platforms.

        Sunitha Kambhampati created issue -

          People

          • Assignee:
            John H. Embretsen
            Reporter:
            Sunitha Kambhampati
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development