Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 10.2.1.6
    • Fix Version/s: 10.2.1.6
    • Component/s: Test
    • Labels:
      None
    • Bug behavior facts:
      Regression Test Failure

      Description

      I am seeing the following diff in XATest, in a clean subversion client running under DerbyNetClient framework on jdk14 on either Linux or cygwin/xp:

      52a53
      > (1 |PREPARED |false |APP |UserTransaction
      54d54
      < (1 |PREPARED |false |APP |UserTransaction
      Test Failed.

          • End: XATest jdk1.4.2_08 DerbyNetClient 2006-08-03 13:06:22 ***

      Looks like an ordering instability.

      1. derby1640trunkstat01.txt
        0.2 kB
        Yip Ng
      2. derby1640trunkdiff01.txt
        0.7 kB
        Yip Ng

        Activity

        Rick Hillegas added a comment -

        Committed at subversion revision 429365.

        Yip Ng added a comment -

        I mean this is caused by DERBY-1579.

        Yip Ng added a comment -

        I think this is caused by DERBY-1549. I ran the XATest again and I am seeing the diff. Attached is the correct master output for XATest.java.

        Deepa Remesh added a comment -

        If we look at the tinderbox results, this test started failing here: http://www.multinet.no/~solberg/public/Apache/TinderBox_Derby/Limited/testSummary-428125.html

        Two changes went in for this run out of which the candidate causing this is likely DERBY-1579 which falls into the category (change to system catalogs) explained by Mike. I had also seen this diff with the patch for DERBY-1579 and noted the peculiar diff here: http://issues.apache.org/jira/browse/DERBY-1579#action_12425246

        I had not understood how the particular change could cause this diff. Thanks Mike for explaining the possible causes.

        Mike Matrigali added a comment -

        This is the kind of diff that is usally caused by some change to system catalogs that is reflected in a newly created database (adding/removing system catalog, changing the number of rows in new db, changing size of a row in a new db). For more explanation see DERBY-977.

        This test is a .java test so really should be coded to handle the order difference itself. I would feel better if we knew what exact change caused this diff. I took a look through the sun tinderbox, but everyone is very busy
        lately and the run I think caused the problem had 20 or so changes in it:
        http://www.multinet.no/~solberg/public/Apache/DerbyJvm1.4/UpdateInfo/428459.txt

        This test failed for me last night in a sun jdk1.4.2, xp/mks environment:

            • Start: XATest jdk1.4.2_07 DerbyNetClient derbynetclientmats:derbynetclientma
              ts 2006-08-04 03:39:05 ***
              52a53
              > (1 |PREPARED |false |APP |UserTransaction
              54d54
              < (1 |PREPARED |false |APP |UserTransaction
              Test Failed.
            • End: XATest jdk1.4.2_07 DerbyNetClient derbynetclientmats:derbynetclientma
              ts 2006-08-04 03:39:33 ***

          People

          • Assignee:
            Yip Ng
            Reporter:
            Rick Hillegas
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development