Uploaded image for project: 'Derby'
  1. Derby
  2. DERBY-1635

stress.multi fails on 10.1/ibm131/jcc2.4

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Won't Fix
    • Affects Version/s: 10.1.3.2
    • Fix Version/s: None
    • Component/s: Test
    • Labels:
      None
    • Environment:
      windows machine.
    • Bug behavior facts:
      Regression

      Description

                      • Diff file derbynetmats/DerbyNet/multi/stress.diff
          • Start: stress jdk1.3.1 DerbyNet derbynetmats:multi 2006-07-09 01:24:15 ***
            6 del
            < TEST CASE SUMMARY: normal termination
            7 del
            < ...running last checks via final.sql
            7 add
            > TEST CASE SUMMARY: abnormal termination due to error(s) – see test log (./stress/stress.log) for details
            Test Failed.
          • End: stress jdk1.3.1 DerbyNet derbynetmats:multi 2006-07-09 01:28:50 ***
            ------------------------------------------------------

      Generating report for RunSuite derbynetmats null null DerbyNet true
      ------------------ Java Information ------------------
      Java Version: 1.3.1
      Java Vendor: IBM Corporation
      Java home: D:\cloudtst\jartest\ibm131\jre
      Java classpath: D:/cloudtst/jartest/classes/derby.jar;D:/cloudtst/jartest/classes/derbytools.jar;D:/cloudtst/jartest/classes/derbynet.jar;D:/cloudtst/jartest/classes/functionTests.jar;D:/cloudtst/jartest/classes/derbyTesting.jar;D:/cloudtst/jartest/tools/java/jndi/fscontext.jar;D:/cloudtst/jartest/drda/jcc/2.4_latest/db2jcc.jar;D:/cloudtst/jartest/drda/jcc/2.4_latest/db2jcc_license_c.jar;D:/cloudtst/jartest/classes/derbyLocale_zh_TW.jar;D:/cloudtst/jartest/classes/derbyLocale_zh_CN.jar;D:/cloudtst/jartest/classes/derbyLocale_pt_BR.jar;D:/cloudtst/jartest/classes/derbyLocale_ko_KR.jar;D:/cloudtst/jartest/classes/derbyLocale_ja_JP.jar;D:/cloudtst/jartest/classes/derbyLocale_it.jar;D:/cloudtst/jartest/classes/derbyLocale_fr.jar;D:/cloudtst/jartest/classes/derbyLocale_es.jar;D:/cloudtst/jartest/classes/derbyLocale_de_DE.jar;
      OS name: Windows 2000
      OS architecture: x86
      OS version: 5.0
      Java user name: cloudtest
      Java user home: C:\Documents and Settings\cloudtest
      Java user dir: D:\cloudtst\jartest\JarResults.2006-07-07\ibm131_derbynetmats_jcc_2.4_latest
      java.specification.name: Java Platform API Specification
      java.specification.version: 1.3
      --------- Derby Information --------
      JRE - JDBC: J2SE 1.3 - JDBC 2.1
      [D:\cloudtst\jartest\classes\derby.jar] 10.1.3.2 - (419765)
      [D:\cloudtst\jartest\classes\derbytools.jar] 10.1.3.2 - (419765)
      [D:\cloudtst\jartest\classes\derbynet.jar] 10.1.3.2 - (419765)
      [D:\cloudtst\jartest\drda\jcc\2.4_latest\db2jcc.jar] 2.4 - (19)
      [D:\cloudtst\jartest\drda\jcc\2.4_latest\db2jcc_license_c.jar] 2.4 - (19)
      ------------------------------------------------------

        Issue Links

          Activity

          skambha Sunitha Kambhampati added a comment -

          Please note: For some reason I was looking at an old test run history - for the week of 07/07 and came across this failure. With a recent build 10.1.3.2 - (426357)., this test does not fail.

          knutanders Knut Anders Hatlen added a comment -

          I have seen the same diff on trunk (revision 516327 running on Solaris 10 with Java SE 6). I'm not sure whether it's exactly the same error, since the actual error is shown in stress.log, not in the diff. In my run, it failed with the Derby network client driver, not with JCC, but the error seems to have happened on the server side, so it could be the same bug. According to derby.log, the test failed because of a NullPointerException with this stack trace:

          java.lang.NullPointerException
          at org.apache.derby.impl.jdbc.EmbedPreparedStatement.getMetaData(EmbedPreparedStatement.java:1066)
          at org.apache.derby.impl.drda.DRDAConnThread.writeSQLDARD(DRDAConnThread.java:6085)
          at org.apache.derby.impl.drda.DRDAConnThread.processCommands(DRDAConnThread.java:756)
          at org.apache.derby.impl.drda.DRDAConnThread.run(DRDAConnThread.java:275)

          Tester2.log (log for the thread that failed), ends like this:

          select * from main2;
          ERROR XJ001: DERBY SQL error: SQLCODE: -1, SQLSTATE: XJ001, SQLERRMC: java.lang.NullPointerExceptionXJ001.U

          The exception was thrown by the last line of this workaround in EmbedPreparedStatement.getMetaData():

          //bug 4579 - gcDuringGetMetaData will be null if this is the first time
          //getMetaData call is made.
          //Second check - if the statement was revalidated since last getMetaData call,
          //then gcDuringGetMetaData wouldn't match with current generated class name
          if (gcDuringGetMetaData == null || gcDuringGetMetaData.equals(execp.getActivationClass().getName()) == false)

          { rMetaData = null; gcDuringGetMetaData = execp.getActivationClass().getName(); }

          I would assume getActivationClass() returned null (I find it less likely that execp was null).

          kmarsden Kathey Marsden added a comment -

          Won't fix since jdk 1.3.1 is no longer supported.

          kristwaa Kristian Waagan added a comment -

          Closing the issue. Note that there is at least one other Jira probably describing the same problem.


            People

            • Assignee:
              Unassigned
              Reporter:
              skambha Sunitha Kambhampati
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development