Derby
  1. Derby
  2. DERBY-1391

Remove ids in SQLState.java and MessageId.java that do not have matching messages and are not used in the code

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Services
    • Labels:
      None

      Description

      The new test I checked in, i18n/MessageBundleTest.java, currently prints out a number of message ids that do not have matching messages in messages_en.properties. This JIRA is to hang the work of getting rid of all ids in SQLState.java and MessageId.java which are in this list and which also are not used in the code.

      Those message ids that are used in the code are more serious, and will be logged as separate bugs.

        Activity

        David Van Couvering created issue -
        David Van Couvering made changes -
        Field Original Value New Value
        Component/s Services [ 11415 ]
        Kathey Marsden made changes -
        Fix Version/s 10.2.0.0 [ 11187 ]
        Daniel John Debrunner added a comment -

        Seems like this is an improvement and not a bug.

        Daniel John Debrunner made changes -
        Issue Type Bug [ 1 ] Improvement [ 4 ]
        Kathey Marsden added a comment -

        dup of DERBY-3902,

        Kathey Marsden made changes -
        Resolution Duplicate [ 3 ]
        Status Open [ 1 ] Resolved [ 5 ]
        Kathey Marsden made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Gavin made changes -
        Workflow jira [ 12373615 ] Default workflow, editable Closed status [ 12799832 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            David Van Couvering
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development