Derby
  1. Derby
  2. DERBY-112

Variable name 'enum' used in a couple of places

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 10.2.1.6
    • Component/s: Build tools
    • Labels:
      None
    • Environment:
      win xp

      Description

      I noticed the variable name 'enum' was used in a couple of places like SQLParser.java and ij.java. 'enum' is now a keyword in Java 1.5. I just changed the variable name to avoid any future conflicts.

      This is my first code submission. Please let me know if all changes submitted should be linked to a corresponding item in JIRA?

        Issue Links

          Activity

          Jonathan Nash created issue -
          Jonathan Nash added a comment -

          Just realized the code gets generated when derby is built. The change will have to be in the code generation.

          Andrew McIntyre made changes -
          Field Original Value New Value
          Link This issue is duplicated by DERBY-111 [ DERBY-111 ]
          Mike Matrigali made changes -
          Description I noticed the variable name 'enum' was used in a couple of places like SQLParser.java and ij.java. 'enum' is now a keyword in Java 1.5. I just changed the variable name to avoid any future conflicts.

          This is my first code submission. Please let me know if all changes submitted should be linked to a corresponding item in JIRA?
          I noticed the variable name 'enum' was used in a couple of places like SQLParser.java and ij.java. 'enum' is now a keyword in Java 1.5. I just changed the variable name to avoid any future conflicts.

          This is my first code submission. Please let me know if all changes submitted should be linked to a corresponding item in JIRA?
          Component/s SQL [ 11408 ]
          Andrew McIntyre made changes -
          Link This issue is related to DERBY-73 [ DERBY-73 ]
          Andrew McIntyre added a comment -

          Linking this issue to DERBY-73. The code generated by javacc 3.1 uses enumerations called "enum" which is now a keyword in Java 1.5/5.0. This is probably a duplicate of DERBY-73, but I'm leaving this open until there is time to investigate further.

          Andrew McIntyre made changes -
          Component/s Build tools [ 11405 ]
          Component/s SQL [ 11408 ]
          Andrew McIntyre added a comment -

          This issue has been resolved by the move to JavaCC 4.0.

          Andrew McIntyre made changes -
          Resolution Fixed [ 1 ]
          Fix Version/s 10.2.0.0 [ 11187 ]
          Status Open [ 1 ] Resolved [ 5 ]
          Andrew McIntyre added a comment -

          This issue has been resolved for over a year with no further movement. Closing.

          Andrew McIntyre made changes -
          Status Resolved [ 5 ] Closed [ 6 ]
          Gavin made changes -
          Workflow jira [ 39159 ] Default workflow, editable Closed status [ 12800353 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Jonathan Nash
            • Votes:
              1 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development