Details

    • Type: Task Task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.1-incubating
    • Fix Version/s: 0.1-incubating
    • Component/s: Core
    • Labels:
      None

      Activity

      Gerhard Petracek added a comment -

      the new approach works for all tests which don't change the project-stage (currently such tests don't get copied). if we need to execute such tests within a remote container, we will create a new ticket.

      Mark Struberg added a comment -

      I'll give it a run this afternoon.

      Gerhard Petracek added a comment -

      imo we can close it and mark opens a new issue for the new approach (autom. copy of tests to the integration-test module to execute the tests in different containers to ensure that the cdi integration won't cause an issue and to avoid c&p of tests)

      Jason Porter added a comment -

      Are we still saying this is reopened, or are we good to close it?

      Christian Kaltepoth added a comment -

      I cannot reproduce this. The integration tests are working fine for me.

      Even after manually deleting the activation jars from my local repository Maven downloads activation-1.1.jar and the build runs fine.

      Mark Struberg added a comment -

      I fear this is not working atm.

      Seems like the JBoss nexus contains broken artifacts (again).

      [ERROR] Failed to execute goal on project integration-test: Could not resolve dependencies for project org.apache.deltaspike.core:integration-test:jar:0.1-SNAPSHOT: Could not find artifact javax.activation:activation:jar:1.0.2 in Apache Snapshot Repository (https://repository.apache.org/content/repositories/snapshots)

      I fear some jboss artifact on maven.central includes a <repositories> section pointing at the jboss repo. And this in turn points to an artifact which exists in neither one.

      Jason Porter added a comment -

      Initial setup for the test structure of unit tests and integration tests is complete.


        People

        • Assignee:
          Jason Porter
          Reporter:
          Jason Porter
        • Votes:
          0 Vote for this issue
          Watchers:
          0 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development