Commons Dbcp
  1. Commons Dbcp
  2. DBCP-349

Insert clob or blob with oracle connection crashes software

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Invalid
    • Affects Version/s: 1.3
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      windows XP , JDK 1.6, oracle 10g, oracle driver 10.2.0.2

      Description

      1> tomcat 6.0.26 has tomcat-dbcp.jar that works completely fine.

      2> tomcat 6.0.28, tomcat 6.0.29, tomcat 5.0.30, tomcat 5.0.31 has tomcat-dbcp.jar file that doesn't work and throws following error :

      java.lang.ClassCastException: org.apache.tomcat.dbcp.dbcp.PoolableConnection cannot be cast to oracle.jdbc.OracleConnection
      at oracle.sql.CLOB.createTemporary(CLOB.java:754)
      at oracle.sql.CLOB.createTemporary(CLOB.java:716)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)

      Would like to know if there was any changes to the commons dbcp package for tomcat version 6.0.29?

      1. DBCP349.zip
        2.22 MB
        Arnaud Brunet

        Activity

        Renaud Bruyeron added a comment -


        Is this really fixed? I looked into the SVN logs and cannot find the relevant commits.

        Phil Steitz added a comment -

        You are correct that there were no DBCP commits on this issue. It was closed by the original reporter. Status should have been INVALID or NOT_A_PROBLEM since there was no fix applied. Feel free to reopen.

        alina joshi added a comment -

        I have closed this issue as I got an email message from you stating it was fixed in DBCP 1.3.1 version.

        Phil Steitz added a comment -

        Sorry, Alina. I see what happened now. I changed the "fix version" to 1.3.1/1.4.1 and that generated an email to you telling you about the issue status change. When we update the "fix version" we are just indicating that we plan to fix the bug in that version, not necessarily that we have already fixed it. Thanks for the bug report and sorry I misinterpreted the close action.

        Thanks, Renaud for pointing out that it had been closed without a committed fix.

        Patches, of course welcome!

        Thomas WERMESTER added a comment -

        Hi, same problem appear on new release tomcat 6 => version 6.0.35

        Renaud Bruyeron added a comment -


        FYI, the stacktrace is missing the top of the stack, but in our case (a spring/hibernate application) there is a workaround at the application level: one must use CommonsDbcpNativeJdbcExtractor instead of SimpleNativeJdbcExtractor.

        Arnaud Brunet added a comment -

        Hi

        It's not a bug of Commons Dbcp.

        Oracle (in CLOB.createTemporary()) casts the Connection to OracleConnection instead to use connection.unwrap method.

        Arnaud Brunet added a comment -

        Attached is a program to understand the error

        Mark Thomas added a comment -

        Resolving this as invalid based on previous comment.


          People

          • Assignee:
            Unassigned
            Reporter:
            alina joshi
          • Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development