DayTrader
  1. DayTrader
  2. DAYTRADER-64

OpenJPA PCEnhancer ant task failure cause Full EJB3 runtime mode failure

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.3, 2.2
    • Fix Version/s: 2.1.3, 2.2
    • Component/s: EJB Tier
    • Labels:
      None
    • Environment:

      JDK 1.6
      OpenJPA 1.2.0

      Description

      Daytrader 2.2-snapshot EJB module build failure cause of missing some dependency package.

      The failure exception like:
      [INFO] [antrun:run

      {execution: default}

      ]
      [INFO] Executing tasks
      [java] java.lang.NoClassDefFoundError: serp.bytecode.Instruction
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:180)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:710)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:178)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:84)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
      [java] at org.apache.tools.ant.Task.perform(Task.java:364)
      [java] at org.apache.tools.ant.Target.execute(Target.java:341)
      [java] at org.apache.maven.plugin.antrun.AbstractAntMojo.executeTasks(AbstractAntMojo.java:108)
      [java] at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:83)
      [java] at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:451)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:558)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:499)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:478)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:330)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:291)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:142)
      [java] at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
      [java] at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
      [java] at org.apache.maven.cli.MavenCli.main(MavenCli.java:287)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:45)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [java] at java.lang.reflect.Method.invoke(Method.java:599)
      [java] at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      [java] at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      [java] at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      [java] at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      [java] Caused by: java.lang.NoClassDefFoundError: serp.bytecode.Instruction
      [java] at java.lang.J9VMInternals.verifyImpl(Native Method)
      [java] at java.lang.J9VMInternals.verify(J9VMInternals.java:72)
      [java] at java.lang.J9VMInternals.initialize(J9VMInternals.java:134)
      [java] at java.lang.Class.forNameImpl(Native Method)
      [java] at java.lang.Class.forName(Class.java:169)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:119)
      [java] ... 26 more
      [java] Caused by: java.lang.ClassNotFoundException: serp.bytecode.Instruction
      [java] at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1166)
      [java] at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1107)
      [java] at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:983)
      [java] at java.lang.ClassLoader.loadClass(ClassLoader.java:609)
      [java] ... 32 more
      [java] — Nested Exception —
      [java] java.lang.NoClassDefFoundError: serp.bytecode.Instruction
      [java] at java.lang.J9VMInternals.verifyImpl(Native Method)
      [java] at java.lang.J9VMInternals.verify(J9VMInternals.java:72)
      [java] at java.lang.J9VMInternals.initialize(J9VMInternals.java:134)
      [java] at java.lang.Class.forNameImpl(Native Method)
      [java] at java.lang.Class.forName(Class.java:169)
      [java] at org.apache.tools.ant.taskdefs.ExecuteJava.execute(ExecuteJava.java:119)
      [java] at org.apache.tools.ant.taskdefs.Java.run(Java.java:710)
      [java] at org.apache.tools.ant.taskdefs.Java.executeJava(Java.java:178)
      [java] at org.apache.tools.ant.taskdefs.Java.execute(Java.java:84)
      [java] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:275)
      [java] at org.apache.tools.ant.Task.perform(Task.java:364)
      [java] at org.apache.tools.ant.Target.execute(Target.java:341)
      [java] at org.apache.maven.plugin.antrun.AbstractAntMojo.executeTasks(AbstractAntMojo.java:108)
      [java] at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:83)
      [java] at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:451)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:558)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:499)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:478)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:330)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:291)
      [java] at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:142)
      [java] at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:336)
      [java] at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:129)
      [java] at org.apache.maven.cli.MavenCli.main(MavenCli.java:287)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      [java] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:45)
      [java] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:37)
      [java] at java.lang.reflect.Method.invoke(Method.java:599)
      [java] at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      [java] at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      [java] at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      [java] at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      [java] Caused by: java.lang.ClassNotFoundException: serp.bytecode.Instruction
      [java] at org.apache.tools.ant.AntClassLoader.findClassInComponents(AntClassLoader.java:1166)
      [java] at org.apache.tools.ant.AntClassLoader.findClass(AntClassLoader.java:1107)
      [java] at org.apache.tools.ant.AntClassLoader.loadClass(AntClassLoader.java:983)
      [java] at java.lang.ClassLoader.loadClass(ClassLoader.java:609)
      [java] ... 32 more
      [INFO] Executed tasks

        Activity

        Donald Woods added a comment -

        Applied to trunk as Rev752869.

        Donald Woods added a comment -

        Applied to Daytrader 2.1.3 as Rev752859.

        Forrest Xia added a comment -

        Oops, made wrong JIRA operations, got it now. thanks!

        Donald Woods added a comment -

        Don't close a JIRA until the patch has been applied...

        Forrest Xia added a comment -

        Patch available to daytrader trunk 2.2 snapshot, please someone help review and commit before 2.2 release. thanks!

        Forrest Xia added a comment -

        Add dependency packages as follows:
        <dependency>
        <groupId>net.sourceforge.serp</groupId>
        <artifactId>serp</artifactId>
        <version>1.13.1</version>
        <scope>provided</scope>
        </dependency>
        <dependency>
        <groupId>commons-lang</groupId>
        <artifactId>commons-lang</artifactId>
        <version>2.4</version>
        <scope>provided</scope>
        </dependency>
        <dependency>
        <groupId>commons-collections</groupId>
        <artifactId>commons-collections</artifactId>
        <version>3.2.1</version>
        <scope>provided</scope>
        </dependency>


          People

          • Assignee:
            Donald Woods
            Reporter:
            Forrest Xia
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development