Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.1.0
    • Component/s: Infrastructure
    • Labels:
      None

      Description

      I did these commands to do a completely clean build:

      git checkout master
      git clean -xdf
      sbt compile
      sbt updateClassifiers
      

      It produces quite a few error/warning messages that are troubling. If these can be eliminated or even reduced it will be much less confusing for new developers.

      [info] Loading settings from plugins.sbt ...
      [info] Loading project definition from /home/mbeckerle-unencrypted/daffodil/project
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/project/}daffodil-build...
      [info] Done updating.
      [warn] Found version conflict(s) in library dependencies; some are suspected to be binary incompatible:
      [warn] 	* org.codehaus.plexus:plexus-utils:3.0.17 is selected over {2.1, 1.5.5}
      [warn] 	    +- org.apache.maven:maven-settings:3.2.2              (depends on 3.0.17)
      [warn] 	    +- org.apache.maven:maven-repository-metadata:3.2.2   (depends on 3.0.17)
      [warn] 	    +- org.apache.maven:maven-aether-provider:3.2.2       (depends on 3.0.17)
      [warn] 	    +- org.apache.maven:maven-model:3.2.2                 (depends on 3.0.17)
      [warn] 	    +- org.apache.maven:maven-core:3.2.2                  (depends on 3.0.17)
      [warn] 	    +- org.apache.maven:maven-artifact:3.2.2              (depends on 3.0.17)
      [warn] 	    +- org.apache.maven:maven-settings-builder:3.2.2      (depends on 3.0.17)
      [warn] 	    +- org.apache.maven:maven-model-builder:3.2.2         (depends on 3.0.17)
      [warn] 	    +- org.sonatype.plexus:plexus-sec-dispatcher:1.3      (depends on 1.5.5)
      [warn] 	    +- org.eclipse.sisu:org.eclipse.sisu.plexus:0.0.0.M5  (depends on 2.1)
      [warn] 	* com.google.guava:guava:18.0 is selected over {10.0.1, 15.0}
      [warn] 	    +- com.spotify:docker-client:3.5.13                   (depends on 18.0)
      [warn] 	    +- com.fasterxml.jackson.datatype:jackson-datatype-guava:2.6.0 (depends on 15.0)
      [warn] 	    +- org.eclipse.sisu:org.eclipse.sisu.plexus:0.0.0.M5  (depends on 10.0.1)
      [warn] Run 'evicted' to see detailed eviction warnings
      [info] Compiling 1 Scala source to /home/mbeckerle-unencrypted/daffodil/project/target/scala-2.12/sbt-1.0/classes ...
      [info] Done compiling.
      [info] Loading settings from build.sbt ...
      [info] Loading settings from build.sbt ...
      [info] Loading settings from build.sbt ...
      [info] Loading settings from build.sbt ...
      [info] Resolving key references (10042 settings) ...
      [info] Set current project to daffodil (in build file:/home/mbeckerle-unencrypted/daffodil/)
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil...
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-propgen...
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-macro-lib...
      [info] Done updating.
      [info] Done updating.
      [info] Done updating.
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-lib...
      [info] Done updating.
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-io...
      [info] Done updating.
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-runtime1...
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [info] Done updating.
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-runtime1-unparser...
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [error] a required artifact is not listed by module descriptor: *#*!*.*
      [info] Done updating.
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-core...
      [info] Done updating.
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-japi...
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-sapi...
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-tdml...
      [info] Done updating.
      [info] Done updating.
      [info] Done updating.
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-tutorials...
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-test...
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-test-ibm1...
      [info] Updating {file:/home/mbeckerle-unencrypted/daffodil/}daffodil-test-stdLayout...
      [info] Done updating.
      [info] Done updating.
      [info] Done updating.
      [info] Done updating.
      [success] Total time: 6 s, completed Dec 28, 2017 11:49:33 AM
      mbeckerle@cat:~/dataiti/git/daffodil$ 
      

        Attachments

          Activity

            People

            • Assignee:
              slawrence Steve Lawrence
              Reporter:
              mbeckerle Michael Beckerle
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: