Uploaded image for project: 'CXF'
  1. CXF
  2. CXF-8212

Reference parameters are not sent as SOAP Headers

Attach filesAttach ScreenshotAdd voteVotersWatch issueWatchersCreate sub-taskLinkCloneUpdate Comment AuthorReplace String in CommentUpdate Comment VisibilityDelete Comments
    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 3.3.5
    • Fix Version/s: None
    • Component/s: JAX-WS Runtime
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      The reference parameters are not sent as soap headers.

      This could be seen on samples/callback: the reference parameters testParameter1 and testParameter2 are present in the endpoint reference:

          <wsa:ReferenceParameters>
              <testParameter1>testValue1</testParameter1>
              <testParameter2>testValue2</testParameter2>
          </wsa:ReferenceParameters>
      

      And are expected to be sent as soap headers, but none of them could be seen in the soap request:

      <soap:Envelope
      	xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
      	<soap:Body>
      		<ns2:callback_message
      			xmlns="http://www.w3.org/2005/08/addressing"
      			xmlns:ns2="http://apache.org/callback">maks</ns2:callback_message>
      	</soap:Body>
      </soap:Envelope>
      

       
      As stated in javadoc of javax.xml.ws.EndpointReference.getPort:

      If there are any reference parameters in the EndpointReference instance, then those reference parameters MUST appear as SOAP headers, indicating them to be reference parameters, on all messages sent to the endpoint.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              maks M Grechuhin

              Dates

              • Created:
                Updated:

                Issue deployment