Uploaded image for project: 'CXF'
  1. CXF
  2. CXF-7431

Apache CXF ws-discovery 3.0.4 not working with WSO2 G-REG 5.3.0

    XMLWordPrintableJSON

    Details

    • Type: Test
    • Status: Open
    • Priority: Blocker
    • Resolution: Unresolved
    • Affects Version/s: 3.0.4, 3.1.11
    • Fix Version/s: None
    • Component/s: WS-* Components
    • Labels:
      None
    • Estimated Complexity:
      Unknown
    • Flags:
      Important

      Description

      Hi,
      I am using cxf 3.0.4-redhat-*, Jboss Fuse 6.2.1 and WSO2 Governance Registry 5.3.0.

      I have my WSO2 G-REG up and running. Now I want as my each and every fuse bundle having CXF services (SOAP/REST) should register themselves automatically as soon as they are installed in Fuse and de-register when uninstalled. I used CXF WS-Discovery feature and added a configuration as per documentation http://cxf.apache.org/docs/ws-discovery.html. I have done proper steps, debugged the code, Hello/Bye operations are getting invoked (sometimes using proxyService url https://localhost:9443/services/DiscoveryProxy?wsdl and sometimes soap.udp://239.255.255.250:3702) whenever I install/uninstall my bundle - but the problem is nothing is happening in WSO2 G-REG side - I mean services are getting visible in WSO2 G-REG.

      Can someone help me on this?

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              vbondoo7 Vishal Saxena
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: