CXF
  1. CXF
  2. CXF-4291

Wadl2java tool executing by cxf-wadl2java-plugin fails if run without tuning JAVA Garbage Collection

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.5.4, 2.6.1
    • Component/s: JAX-RS, Tooling
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      With several examples tha includes distinct grammars external schemes, the wadl2java tool fails if no executed "mvn generate-sources" with memory tunning java params. The error message:

      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 8.815s
      [INFO] Finished at: Mon May 07 08:13:29 BST 2012
      [INFO] Final Memory: 5M/27M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.cxf:cxf-wadl2java-plugin:2.6.0:wadl2java (generate-sources) on project cxf_2_6_0_wadl: java.lang.RuntimeException: No XmlSchema in SchemaInfo -> [Help 1]
      [ERROR]

      The problem is the class "org.apache.cxf.service.model.SchemaInfo" that uses "org.apache.cxf.service.model.SoftReference". This implies that
      the garbage collector resets Namespaces declared in a previous import.

      Example:

      <grammars>
      <include href="../sdmx21/SDMXMessage.xsd"/>
      <include href="SDMXRestTypes.xsd"/>
      </grammars>

      And the SDMXRestTypes.xsd references SDMXMessage.xsd namespaces.

      Executed maven task with for example -Xms512M -Xmx1024M is successful.

      1. cxf_2_6_0_wadl.zip
        351 kB
        Zebensui Méndez

        Activity

        Zebensui Méndez added a comment -

        Example project with bug

        Sergey Beryozkin added a comment -

        I've added the following hint to the WADL-first section:
        "Note that the minimum and maximum memory limits may need to be increased when using the plugin to process large WADL documents, for example, add '-Xms512M -Xmx1024M' to the list of Maven options."

        IMHO this would be a good resolution to this issue ?

        Zebensui Méndez added a comment -

        Is a quickly solution, i don't know if is a good resolution. The problem is the error message: "java.lang.RuntimeException: No XmlSchema in SchemaInfo", it not leads to the obvious solution to increase the heap space.But reading the doc is a good solution.

        Thank you.

        Sergey Beryozkin added a comment -

        I agree. I see SourceGenerator does not initialize XmlSchema reference on SchemaInfo, but only its DOM Element representation.
        I'll investigate later on what else can be done...

        Sergey Beryozkin added a comment -

        Hi, I can not reproduce an actual issue on my laptop, presumably due to it having enough memory for the schema compilation to succeed.

        However, I updated the generator to attempt to prevent such issues,
        http://svn.apache.org/viewvc?rev=1343210&view=rev

        Please try with the snapshots or the soon to be released CXF 2.5.4 or 2.6.1, thanks


          People

          • Assignee:
            Sergey Beryozkin
            Reporter:
            Zebensui Méndez
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development