CXF
  1. CXF
  2. CXF-4193

CXF logbrowser sample not working in 2.6.0

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.6
    • Component/s: Samples
    • Labels:
      None
    • Estimated Complexity:
      Unknown

      Description

      When following the instructions in the README to add the URL http://localhost:9002/log/logs, the following exception occurs is reported by the server:

      Caused by: org.apache.cxf.interceptor.Fault
      at org.apache.cxf.service.invoker.AbstractInvoker.createFault(AbstractInvoker.java:154)
      at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:120)
      at org.apache.cxf.jaxrs.JAXRSInvoker.invoke(JAXRSInvoker.java:167)
      at org.apache.cxf.jaxrs.JAXRSInvoker.invoke(JAXRSInvoker.java:94)
      at org.apache.cxf.interceptor.ServiceInvokerInterceptor$1.run(ServiceInvokerInterceptor.java:58)
      at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
      at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
      at java.util.concurrent.FutureTask.run(FutureTask.java:138)
      at org.apache.cxf.workqueue.SynchronousExecutor.execute(SynchronousExecutor.java:37)
      at org.apache.cxf.interceptor.ServiceInvokerInterceptor.handleMessage(ServiceInvokerInterceptor.java:106)
      at org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptorChain.java:262)
      ... 32 more
      Caused by: java.lang.NullPointerException
      at org.apache.cxf.management.web.logging.atom.AtomPullServer.getCurrentCondition(AtomPullServer.java:277)
      at org.apache.cxf.management.web.logging.atom.AtomPullServer.getXmlFeedWithPage(AtomPullServer.java:165)
      at org.apache.cxf.management.web.logging.atom.AtomPullServer.getXmlFeed(AtomPullServer.java:146)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.cxf.service.invoker.AbstractInvoker.performInvocation(AbstractInvoker.java:172)
      at org.apache.cxf.service.invoker.AbstractInvoker.invoke(AbstractInvoker.java:88)

        Activity

        Glen Mazza created issue -
        Sergey Beryozkin made changes -
        Field Original Value New Value
        Assignee Sergey Beryozkin [ sergey_beryozkin ]
        Sergey Beryozkin made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        Glen Mazza added a comment -

        I can no longer replicate this issue on CXF 2.6.0; Sergey may close this issue when he wishes.

        Sergey Beryozkin added a comment -

        I saw the problem at Ubuntu - but given that it works for Glen on Ubuntu I'm closing it for now, will retry the demo after the Ubuntu upgrade

        Sergey Beryozkin made changes -
        Status In Progress [ 3 ] Resolved [ 5 ]
        Fix Version/s 2.6 [ 12319252 ]
        Resolution Fixed [ 1 ]
        Daniel Kulp made changes -
        Status Resolved [ 5 ] Closed [ 6 ]

          People

          • Assignee:
            Sergey Beryozkin
            Reporter:
            Glen Mazza
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development