Uploaded image for project: 'Apache Curator'
  1. Apache Curator
  2. CURATOR-428

NoSuchFieldError for configFileStr in QuorumConfigBuilder

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Not A Problem
    • Affects Version/s: 4.0.0
    • Fix Version/s: None
    • Component/s: Tests
    • Labels:
      None

      Description

      Exception in thread "Thread-0" java.lang.NoSuchFieldError: configFileStr
      at org.apache.curator.test.QuorumConfigBuilder$1.<init>(QuorumConfigBuilder.java:142)
      at org.apache.curator.test.QuorumConfigBuilder.buildConfig(QuorumConfigBuilder.java:137)
      at org.apache.curator.test.TestingZooKeeperServer$1.run(TestingZooKeeperServer.java:157)
      at java.lang.Thread.run(Thread.java:745)

        Activity

        Hide
        randgalt Jordan Zimmerman added a comment -

        It seems like you're bringing in an older version of ZooKeeper maybe? That type of error can only be caused by a bad dependency.

        Show
        randgalt Jordan Zimmerman added a comment - It seems like you're bringing in an older version of ZooKeeper maybe? That type of error can only be caused by a bad dependency.
        Hide
        linux_china Jacky Chan added a comment -

        yes, My ZooKeep version is 3.4.10. Could you make Curator 4 compatible with ZooKeeper 3.4.x?

        Show
        linux_china Jacky Chan added a comment - yes, My ZooKeep version is 3.4.10. Could you make Curator 4 compatible with ZooKeeper 3.4.x?
        Hide
        randgalt Jordan Zimmerman added a comment -

        Curator 4.0.0 is compatible with ZooKeeper 3.4 - have you seen the release notes? http://curator.apache.org/zk-compatibility.html - however, you're probably using version 4.0.0 of curator-testing. Please use version 2.12.0 of curator-test instead. I'll update the docs at some point to make this more clear.

        Show
        randgalt Jordan Zimmerman added a comment - Curator 4.0.0 is compatible with ZooKeeper 3.4 - have you seen the release notes? http://curator.apache.org/zk-compatibility.html - however, you're probably using version 4.0.0 of curator-testing. Please use version 2.12.0 of curator-test instead. I'll update the docs at some point to make this more clear.

          People

          • Assignee:
            Unassigned
            Reporter:
            linux_china Jacky Chan
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development