Details

    • Type: Test
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Client, Framework, Recipes
    • Labels:
      None

      Description

      It's about time we update the versions of our dependencies. Get the latest Apache parent POM, Maven plugins, etc.

        Issue Links

          Activity

          githubbot ASF GitHub Bot added a comment -

          GitHub user lvfangmin opened a pull request:

          https://github.com/apache/curator/pull/204

          CURATOR-378 Update mvn parent pom, plugin and other dependency version

          Update the dependencies version to the version which is most widely used.

          You can merge this pull request into a Git repository by running:

          $ git pull https://github.com/lvfangmin/curator update_dependency

          Alternatively you can review and apply these changes as the patch at:

          https://github.com/apache/curator/pull/204.patch

          To close this pull request, make a commit to your master/trunk branch
          with (at least) the following in the commit message:

          This closes #204


          commit c8e9f93dfd4a0f5e21c23b314b142e148c61b234
          Author: Fangmin Lyu <allenlyu@fb.com>
          Date: 2017-03-11T23:59:45Z

          update mvn parent pom, plugin and other dependency version


          githubbot ASF GitHub Bot added a comment -

          Github user cammckenzie commented on a diff in the pull request:

          https://github.com/apache/curator/pull/204#discussion_r105800775

          — Diff: pom.xml —
          @@ -62,22 +62,22 @@

          <!-- versions -->
          <zookeeper-version>3.4.8</zookeeper-version>

          • <maven-project-info-reports-plugin-version>2.7</maven-project-info-reports-plugin-version>
          • <maven-bundle-plugin-version>2.3.7</maven-bundle-plugin-version>
          • <maven-javadoc-plugin-version>2.10.3</maven-javadoc-plugin-version>
          • <doxia-module-confluence-version>1.6</doxia-module-confluence-version>
            + <maven-project-info-reports-plugin-version>2.9</maven-project-info-reports-plugin-version>
            + <maven-bundle-plugin-version>3.2.0</maven-bundle-plugin-version>
            + <maven-javadoc-plugin-version>2.10.4</maven-javadoc-plugin-version>
            + <doxia-module-confluence-version>1.7</doxia-module-confluence-version>
            <maven-license-plugin-version>1.9.0</maven-license-plugin-version>
          • <javassist-version>3.18.1-GA</javassist-version>
            + <javassist-version>3.20.0-GA</javassist-version>
            <commons-math-version>2.2</commons-math-version>
            <jackson-mapper-asl-version>1.9.13</jackson-mapper-asl-version>
            <jersey-version>1.18.1</jersey-version>
            <jsr311-api-version>1.1.1</jsr311-api-version>
            <jetty-version>6.1.26</jetty-version>
            <scannotation-version>1.0.2</scannotation-version>
            <resteasy-jaxrs-version>2.3.0.GA</resteasy-jaxrs-version>
          • <guava-version>16.0.1</guava-version>
            + <guava-version>19.0</guava-version>
              • End diff –

          Is there a reason this is 19.0 instead of 20.0? I see we can't go to 21.0 because it's got a Java 1.8 dependency, but 20 should be ok?

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on a diff in the pull request:

          https://github.com/apache/curator/pull/204#discussion_r105804055

          — Diff: pom.xml —
          @@ -62,22 +62,22 @@

          <!-- versions -->
          <zookeeper-version>3.4.8</zookeeper-version>

          • <maven-project-info-reports-plugin-version>2.7</maven-project-info-reports-plugin-version>
          • <maven-bundle-plugin-version>2.3.7</maven-bundle-plugin-version>
          • <maven-javadoc-plugin-version>2.10.3</maven-javadoc-plugin-version>
          • <doxia-module-confluence-version>1.6</doxia-module-confluence-version>
            + <maven-project-info-reports-plugin-version>2.9</maven-project-info-reports-plugin-version>
            + <maven-bundle-plugin-version>3.2.0</maven-bundle-plugin-version>
            + <maven-javadoc-plugin-version>2.10.4</maven-javadoc-plugin-version>
            + <doxia-module-confluence-version>1.7</doxia-module-confluence-version>
            <maven-license-plugin-version>1.9.0</maven-license-plugin-version>
          • <javassist-version>3.18.1-GA</javassist-version>
            + <javassist-version>3.20.0-GA</javassist-version>
            <commons-math-version>2.2</commons-math-version>
            <jackson-mapper-asl-version>1.9.13</jackson-mapper-asl-version>
            <jersey-version>1.18.1</jersey-version>
            <jsr311-api-version>1.1.1</jsr311-api-version>
            <jetty-version>6.1.26</jetty-version>
            <scannotation-version>1.0.2</scannotation-version>
            <resteasy-jaxrs-version>2.3.0.GA</resteasy-jaxrs-version>
          • <guava-version>16.0.1</guava-version>
            + <guava-version>19.0</guava-version>
              • End diff –

          currently, 19.0 is the version which is most widely used, so I picked it, I'm not against of using 20.0 though.

          githubbot ASF GitHub Bot added a comment -

          Github user cammckenzie commented on a diff in the pull request:

          https://github.com/apache/curator/pull/204#discussion_r105804310

          — Diff: pom.xml —
          @@ -62,22 +62,22 @@

          <!-- versions -->
          <zookeeper-version>3.4.8</zookeeper-version>

          • <maven-project-info-reports-plugin-version>2.7</maven-project-info-reports-plugin-version>
          • <maven-bundle-plugin-version>2.3.7</maven-bundle-plugin-version>
          • <maven-javadoc-plugin-version>2.10.3</maven-javadoc-plugin-version>
          • <doxia-module-confluence-version>1.6</doxia-module-confluence-version>
            + <maven-project-info-reports-plugin-version>2.9</maven-project-info-reports-plugin-version>
            + <maven-bundle-plugin-version>3.2.0</maven-bundle-plugin-version>
            + <maven-javadoc-plugin-version>2.10.4</maven-javadoc-plugin-version>
            + <doxia-module-confluence-version>1.7</doxia-module-confluence-version>
            <maven-license-plugin-version>1.9.0</maven-license-plugin-version>
          • <javassist-version>3.18.1-GA</javassist-version>
            + <javassist-version>3.20.0-GA</javassist-version>
            <commons-math-version>2.2</commons-math-version>
            <jackson-mapper-asl-version>1.9.13</jackson-mapper-asl-version>
            <jersey-version>1.18.1</jersey-version>
            <jsr311-api-version>1.1.1</jsr311-api-version>
            <jetty-version>6.1.26</jetty-version>
            <scannotation-version>1.0.2</scannotation-version>
            <resteasy-jaxrs-version>2.3.0.GA</resteasy-jaxrs-version>
          • <guava-version>16.0.1</guava-version>
            + <guava-version>19.0</guava-version>
              • End diff –

          I don't really have a strong preference either way, I don't use guava a great deal outside Curator, so I'm happy to defer to those who use it more. @Randgalt?

          githubbot ASF GitHub Bot added a comment -

          Github user hdeadman commented on the issue:

          https://github.com/apache/curator/pull/204

          They deleted at least one method in guava 21 that curator is still using. I am trying to use http://github.com/apereo/cas with spring-cloud-zookeeper and I need to use an older version of guava or I get a NoSuchMethodError error. I can probably get away with using an older version of guava in CAS but it would be nice if curator worked with 21.

          ```java
          Caused by: java.lang.NoSuchMethodError: com.google.common.util.concurrent.MoreExecutors.sameThreadExecutor()Lcom/google/common/util/concurrent/ListeningExecutorService;
          at org.apache.curator.framework.listen.ListenerContainer.addListener(ListenerContainer.java:41) ~[curator-framework-2.10.0.jar:?]
          at org.apache.curator.framework.imps.CuratorFrameworkImpl.start(CuratorFrameworkImpl.java:257) ~[curator-framework-2.10.0.jar:?]
          at org.springframework.cloud.zookeeper.ZookeeperAutoConfiguration.curatorFramework(ZookeeperAutoConfiguration.java:70) ~[spring-cloud-zookeeper-core-1.0.3.RELEASE.jar:1.0.3.RELEASE]
          ```

          Here is where they deleted the deprecated method: [Guava commit](https://github.com/google/guava/commit/f67ab864bde63fa6602b5688de0440957ffeaa2e#diff-7a493427c77df959295f1d55574dbd50)

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          @hdeadman as of Curator 2.12.0/3.3.0 Guava is shaded into Curator and there should be no more dependency clashes.

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on a diff in the pull request:

          https://github.com/apache/curator/pull/204#discussion_r106074510

          — Diff: pom.xml —
          @@ -62,22 +62,22 @@

          <!-- versions -->
          <zookeeper-version>3.4.8</zookeeper-version>

          • <maven-project-info-reports-plugin-version>2.7</maven-project-info-reports-plugin-version>
          • <maven-bundle-plugin-version>2.3.7</maven-bundle-plugin-version>
          • <maven-javadoc-plugin-version>2.10.3</maven-javadoc-plugin-version>
          • <doxia-module-confluence-version>1.6</doxia-module-confluence-version>
            + <maven-project-info-reports-plugin-version>2.9</maven-project-info-reports-plugin-version>
            + <maven-bundle-plugin-version>3.2.0</maven-bundle-plugin-version>
            + <maven-javadoc-plugin-version>2.10.4</maven-javadoc-plugin-version>
            + <doxia-module-confluence-version>1.7</doxia-module-confluence-version>
            <maven-license-plugin-version>1.9.0</maven-license-plugin-version>
          • <javassist-version>3.18.1-GA</javassist-version>
            + <javassist-version>3.20.0-GA</javassist-version>
            <commons-math-version>2.2</commons-math-version>
            <jackson-mapper-asl-version>1.9.13</jackson-mapper-asl-version>
            <jersey-version>1.18.1</jersey-version>
            <jsr311-api-version>1.1.1</jsr311-api-version>
            <jetty-version>6.1.26</jetty-version>
            <scannotation-version>1.0.2</scannotation-version>
            <resteasy-jaxrs-version>2.3.0.GA</resteasy-jaxrs-version>
          • <guava-version>16.0.1</guava-version>
            + <guava-version>19.0</guava-version>
              • End diff –

          As we now shade Guava into Curator I don't think it's that big of a deal which version we put in our POM. I'd say use the most commonly used version so that we don't screw up anyone else's build.

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          This doesn't compile. TestStringsWithRestEasy.java is using `ByteStreams.newInputStreamSupplier()` which no longer exists in Guava.

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on the issue:

          https://github.com/apache/curator/pull/204

          I had run compile, it works, haven't checked tests though, I'll fix the tests.

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on the issue:

          https://github.com/apache/curator/pull/204

          Test passed on my dev server:
          $ mvn clean test

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          @lvfangmin can you redo this on the new master? Sorry about this.

          githubbot ASF GitHub Bot added a comment -

          Github user beihaifeiwu commented on the issue:

          https://github.com/apache/curator/pull/204

          Hi @Randgalt, I am using curator 2.12.0 , but the class org.apache.curator.framework.listen.ListenerContainer is still use guava utils directly not the shaded one

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          @beihaifeiwu Yes, that's correct. See https://cwiki.apache.org/confluence/display/CURATOR/TN13 for details.

          githubbot ASF GitHub Bot added a comment -

          Github user beihaifeiwu commented on the issue:

          https://github.com/apache/curator/pull/204

          ```java
          @Override
          public void addListener(T listener)

          { addListener(listener, MoreExecutors.sameThreadExecutor()); }

          ```
          but this code use the com.google.common.util.concurrent.MoreExecutors´╝îIs this correct ?

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          `MoreExecutors` is shaded. If you look inside the JAR and/or decompile those classes you'll it. We use Maven's shade plugin to do this at compile time.

          githubbot ASF GitHub Bot added a comment -

          Github user beihaifeiwu commented on the issue:

          https://github.com/apache/curator/pull/204

          @Randgalt I think the class com.google.common.util.concurrent.MoreExecutors should also use the shaded one as org.apache.curator.shaded.com.google.common.util.concurrent.MoreExecutors

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          I don't understand. `com.google.common.util.concurrent.MoreExecutors` is a Google class not a Curator class.

          githubbot ASF GitHub Bot added a comment -

          Github user beihaifeiwu commented on the issue:

          https://github.com/apache/curator/pull/204

          @Randgalt Sorry about that, I see what you mean, I only see the source code not the decompile.

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          Here's a disassembly of that class from Curator 3.3.0. Notice that all uses of MoreExecutors is the shaded version. https://gist.github.com/Randgalt/3fcdca337a2f8527a3f7ee871852f456

          githubbot ASF GitHub Bot added a comment -

          Github user beihaifeiwu commented on the issue:

          https://github.com/apache/curator/pull/204

          Ok, @Randgalt thanks a lot

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          @lvfangmin Can you bring this PR up to date please?

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on the issue:

          https://github.com/apache/curator/pull/204

          @Randgalt sorry for the delay, rebased onto master, the test is still running on my mac, will make sure everything passed.

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on the issue:

          https://github.com/apache/curator/pull/204

          There are tests failure, those tests also failed before this patch on master, @Randgalt just saw you created Jira: CURATOR-419, is it related? I'll take a look later today.

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          Probably - I should have them fixed in the next day or so

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          Master is building with all tests on Jenkins now. FYI

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on the issue:

          https://github.com/apache/curator/pull/204

          Rebase again, all the tests passed:

          [INFO] ------------------------------------------------------------------------
          [INFO] Reactor Summary:
          [INFO]
          [INFO] Apache Curator ..................................... SUCCESS [ 0.709 s]
          [INFO] Curator Testing .................................... SUCCESS [ 5.251 s]
          [INFO] Curator Client ..................................... SUCCESS [ 32.717 s]
          [INFO] Curator Framework .................................. SUCCESS [21:42 min]
          [INFO] Curator Recipes .................................... SUCCESS [ 01:07 h]
          [INFO] Curator Service Discovery .......................... SUCCESS [02:24 min]
          [INFO] Curator Async ...................................... SUCCESS [06:57 min]
          [INFO] Curator Examples ................................... SUCCESS [ 1.525 s]
          [INFO] Curator Service Discovery Server ................... SUCCESS [ 11.942 s]
          [INFO] Curator RPC Proxy .................................. SUCCESS [ 15.078 s]
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD SUCCESS
          [INFO] ------------------------------------------------------------------------

          githubbot ASF GitHub Bot added a comment -

          Github user Randgalt commented on the issue:

          https://github.com/apache/curator/pull/204

          @lvfangmin can you merge this into master please?

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on the issue:

          https://github.com/apache/curator/pull/204

          Sure, was waiting for a LGTM, I'll merge it today.

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin commented on the issue:

          https://github.com/apache/curator/pull/204

          Has merged this into master.

          (Renamed my local branch to CURATOR-378, and forgot to update here, that's why this is not show as closed, will manually close it.)

          githubbot ASF GitHub Bot added a comment -

          Github user lvfangmin closed the pull request at:

          https://github.com/apache/curator/pull/204


            People

            • Assignee:
              lvfangmin Fangmin Lv
              Reporter:
              randgalt Jordan Zimmerman
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development