As suggested by Josh, I've patched the more generally-applicable stuff from https://github.com/spotify/crunch-lib into org.apache.crunch.lib
- Does all of this belong here?
- Should Percentiles be renamed to Quantiles, given that you actually just specify a 0.0-1.0 range? Quantiles is more accurate, but people are more likely to search for Percentiles.
- Would the DoFns.detach(...) functionality be better implemented as a DetachingReduceFn base class rather than a wrap-and-delegate?