CouchDB
  1. CouchDB
  2. COUCHDB-958

Compacting a database intermittently kills replications

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.0.2
    • Component/s: Replication
    • Labels:
      None
    • Environment:

      Ubuntu 10.04.1, Erlang R13B03

      Description

      Steps to reproduce:

      1. Set up a number of pull replications between server A and server B
      2. Compact one of the databases on server B

      Sometimes, just after the compaction finishes, all the running replications on server B (pulling from server A) will die. For the avoidance of doubt, this includes replications targeting databases other than the one that was being compacted.

      I've discussed this with rnewson on IRC, and he's seen the logs from when the problems occur.

        Activity

        Stephen Lewis created issue -
        Stephen Lewis made changes -
        Field Original Value New Value
        Summary Compact a database intermittently kills replications Compacting a database intermittently kills replications
        Jan Lehnardt added a comment -

        We should get that fixed for 1.0.2.

        Jan Lehnardt made changes -
        Fix Version/s 1.0.2 [ 12315258 ]
        Priority Major [ 3 ] Blocker [ 1 ]
        Filipe Manana added a comment -

        Hi, that was already fixed in trunk and branch 1.0.x. Here's the commit:

        http://svn.apache.org/viewvc?view=revision&revision=1001184

        1.0.2 will include this fix.

        Filipe Manana made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Jan Lehnardt added a comment -

        Guessing from the commit, it changes something in a `retry ->` clause. It looks like the regular case succeeds, but if that particular code has to retry, the problem occurs.


          People

          • Assignee:
            Unassigned
            Reporter:
            Stephen Lewis
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development