CouchDB
  1. CouchDB
  2. COUCHDB-690

replication fail -- couchdb crashed

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 0.10.1
    • Fix Version/s: None
    • Component/s: Replication
    • Environment:

      linux 2.6.30.7 - debian 5.0

    • Skill Level:
      Regular Contributors Level (Easy to Medium)

      Description

      We have a database on host A with 8.5 millions document. The size of the database is ~450GO.

      We first tried to start a continuous replication on a second host B. The replication stoped after only 1Go have been copied, and the replication never started again.

      We then copied the database file from host A on host B. When the file was copied, we started a replication from A to B, then the couchdb on host B crashed. It tooks a long time to fetch a list of IDs, then it appears in the logfile that a time out occured on host B, and immediatly after the couchdb instance on host B crashed.

      1. couch.log
        1.02 MB
        linkfluence

        Activity

        linkfluence created issue -
        linkfluence added a comment -

        log file

        linkfluence made changes -
        Field Original Value New Value
        Attachment couch.log [ 12438606 ]
        linkfluence made changes -
        Description We have a database on host A with 8.5 millions document. The size of the database is ~450GO.

        We first tried to start a continuous replication on a second host B. The replication stoped after only 1Go have been copied, and the replication never started again.

        We then copied the database file from host A on host B. When the file was copied, we started a replication from A to B, then the couchdb on host B crashed. It tooks a long time to fetch a list of IDs, then it appears in the logfile that a time out occured on host B, and immediatly after the couchdb instance on host B crashed.

        log file : http://overmind.rtgi.eu/couch.tgz
        We have a database on host A with 8.5 millions document. The size of the database is ~450GO.

        We first tried to start a continuous replication on a second host B. The replication stoped after only 1Go have been copied, and the replication never started again.

        We then copied the database file from host A on host B. When the file was copied, we started a replication from A to B, then the couchdb on host B crashed. It tooks a long time to fetch a list of IDs, then it appears in the logfile that a time out occured on host B, and immediatly after the couchdb instance on host B crashed.

        Daniel Bechler added a comment -

        I'm having the same issue (and same error log). This happens frequently on a small (<10k docs), but write-heavy (very high update frequency of all docs) database, when replicating from a server in the USA to Europe. Running CouchDB 0.11.0 on both servers.

        Paul Joseph Davis made changes -
        Skill Level Regular Contributors Level (Easy to Medium)
        Benoit Chesneau added a comment -

        how does it works on 1.0.3/1.1 ?

        daniele.testa added a comment -

        Is CouchDB still being developed? This issue is a BIG one and it is over one year old...

        Filipe Manana added a comment -

        Daniele,

        It is. Have you tried on more recent releases? (1.0.x)

        Robert Newson added a comment -

        It is very active, there have been 7 releases since 0.10.1.

        Patrick de Lanauze added a comment -

        this is a showstopper for the use of couchdb in my project..
        any progress on this issue ?

        Robert Newson added a comment -

        0.10.1 is ancient. Is the original poster still active? Inclined to close this ticket as 'Cannot Reproduce' unless someone can reaffirm the bug.

        Paul Joseph Davis added a comment -

        0.10 is super old. The attached logs don't show anything more than an ibrowse connection timing out during replication which isn't informative to debug this even if someone wanted to.

        If someone can reproduce similar error conditions on a version that still is still actively supported then please create a new issue for it.

        Paul Joseph Davis made changes -
        Status Open [ 1 ] Resolved [ 5 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Unassigned
            Reporter:
            linkfluence
          • Votes:
            2 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development