Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 1.0.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Apache CouchDB 1.0.1

      Ubuntu 10.04.2 LTS.

      Description

      Hi,

      Login to server with ordinary user accounts stopped working. Logging in with admin's defined in local.ini still worked, but user account created as documents always responded with username/password incorrect.

      When the old users did not work, we started to create new users in Futon.
      Here are the requests from the logs when a user is created, and the failed login afterwards.
      [Thu, 12 Apr 2012 14:22:57 GMT] [info] [<0.1392.0>] <ip> - - 'PUT' /_users/org.couchdb.user%3Apetter 201
      [Thu, 12 Apr 2012 14:22:57 GMT] [info] [<0.1393.0>] <ip> - - 'POST' /_session 401

      We restarted couch several times using
      $ service couchdb restart
      but it was still impossible to login with an ordinary user.

      The problem was resolved by changing the log level to "debug" in local.ini and a restart.

      After this change the login and sign-up/in process in futon worked fine, and the already created user account worked fine.

      After changing the log level back to info the server continued to work fine.

        Activity

        Petter Olofsson created issue -
        Robert Newson made changes -
        Field Original Value New Value
        Assignee Paul Joseph Davis [ paul.joseph.davis ]
        Dave Cottlehuber made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Cannot Reproduce [ 5 ]

          People

          • Assignee:
            Paul Joseph Davis
            Reporter:
            Petter Olofsson
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development