CouchDB
  1. CouchDB
  2. COUCHDB-1044

Replication fails for documents with many open revisions

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 1.0.2
    • Fix Version/s: 1.0.3, 1.1
    • Component/s: Replication
    • Labels:
      None

      Description

      This is a duplicate of COUCHDB-644. Problem still exists in 1.0.2, so I'm creating this ticket to give it better visibility (the old ticket says 0.9, so will not show up as important on anyone's todo list)

        Issue Links

          Activity

          Robert Newson added a comment -

          The side-effect of making urls longer than 8k (the mochiweb maximum) is that replication cannot replicate documents with lots of open revisions.

          Rachel Willmer added a comment -

          And since replication doesn't go past that error, the effect is that once you have one of these docs, you don't have replication.

          Adam Kocoloski added a comment -

          Fixed the calculation. The new replicator also appears to handle this correctly.


            People

            • Assignee:
              Unassigned
              Reporter:
              Rachel Willmer
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development