Continuum
  1. Continuum
  2. CONTINUUM-401

cannot delete project (stuck on 'in progress')

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0
    • Fix Version/s: 1.0.2
    • Component/s: None
    • Labels:
      None
    • Environment:
      running on linux debian
      trying to access from winXP

      Description

      one of my projects got stuck in the 'in progress' state and cannot be deleted from the web interface.
      it's been in this state for > 24 hrs so it seems permanent.

      attaching screenshot.

      let me know if i should attach a log (and which one)

      1. wrapper-2005-12-21.log
        103 kB
      2. wrapper-2005-11-25.log
        76 kB
      3. palulustuck.JPG
        43 kB
        Adam Kiezun

        Issue Links

          Activity

          Emmanuel Venisse added a comment -

          Fixed by CONTINUUM-478

          Yann Le Du added a comment -

          Using these parameters in continuum/bin/linux/wrapper.conf solved the "out of memory error" for us :
          ...

          1. Initial Java Heap Size (in MB)
            wrapper.java.initmemory=64
          1. Maximum Java Heap Size (in MB)
            wrapper.java.maxmemory=256
            ...

          About the other cases of restart, it finally seems the cause was a concurrent backup process on our server...
          So, in conclusion, I'd say we have no more stability problem with 1.0.2. And if any, thanks to CONTINUUM-478, the projects aren't stuck.

          Yann Le Du added a comment -

          Restart of Continuum could be due to lack of memory. See what I got today : wrapper-2005-12-21.log
          I'm going to try and solve this by changing the Plexus JVM memory options in continuum/bin/linux/wrapper.conf

          Yann Le Du added a comment -

          Aah ! I didn't notice it in precedent tests (I'm quite sure it wasn't there), but Continuum indeed restarted twice last Friday, at 22:01 and 22:32, though I can't tell why (nobody was working at this time). The error is :
          ERROR | wrapper | 2005/11/25 22:32:48 | JVM appears hung: Timed out waiting for signal from JVM.
          ERROR | wrapper | 2005/11/25 22:32:48 | JVM did not exit on request, terminated
          Here is the log : wrapper-20051125.log

          Noticed CONTINUUM-478 and CONTINUUM-479, good idea, thanks !

          Emmanuel Venisse added a comment -

          Can you look at logs if your continuum restart during the night. I can't reproduce a "In Progress" state if i don't restart continuum when it build some projects. In 1.0.2, all project with a state "In Progress" will be repair when continuum will be restart.

          Yann Le Du added a comment -

          Hmm... seems like I was mistaken. I added A again and the projects got stuck even though. Must be something else. Sorry for the wild guess...
          BTW, our repo is not cleaned at night.

          Emmanuel Venisse added a comment -

          strange.
          Can you attache a little sample and some explanations, so i'll try to reproduce it.
          With maven2, all projects are independant, m2 find parent in repository. Do you clean your repo at night?

          Yann Le Du added a comment -

          Yesterday I removed A, and today B & C are frozen.
          Can't tell why it's happening only at night, but it looks like the problem is about missing parent (in 1.0.1). WDYT ?

          Yann Le Du added a comment -

          Maybe my problem is about parents & modules. I have this structure : A parent of B, B parent of C
          When only B and C are all in Continuum, B freezes and C freezes too.
          Yesterday I added A, and today everything is OK.
          I'll keep on testing to see if this really is the source of the problem.

          Emmanuel Venisse added a comment -

          build order is defined by dependencies between projects like the reactor in maven.

          Yann Le Du added a comment -

          Actually I fortunaltely kept the old 1.0.1 directory. There was no error or exception in the log during the night.
          Are the builds sequenced in a certain way (e.g., based on dependencies between projects), or are they totally independent ?

          Yann Le Du added a comment -

          I'm afraid no - at least at the moment - because I switched back to 1.0 (we're in production). But if it can help, I'll setup a 1.0.1 apart and send you any info ASAP.

          Emmanuel Venisse added a comment -

          yann, do you have some explanations in logs like error, exceptions?

          Yann Le Du added a comment -

          Not always. Sometimes the only clean solution is to re-deploy Continuum.
          I had the problem (with Continuum 1.0.1) when, every morning, half of the projects, always the same ones, were stuck "in progress", although the daily builds were OK and Continuum hadn't been stopped at night (I start it by hand). "Build all" didn't change anything : the other projects were built, but these ones remained "in progress".

          Emmanuel Venisse added a comment -

          brett, it doesn't work, because i check project state before add it in queue.

          Brett Porter added a comment -

          you can also unstick it by building all

          André Velle added a comment -

          You can delete the project by "fixing" the link (copy the delete link from another project, change the id).

          Adam Kiezun added a comment -

          btw, this seems related to issue CONTINUUM-369

          Brett Porter added a comment -

          I think this happens when continuum is stopped and a build is in progress. Maybe we need to track the forked build along with the build result, and detect it has been killed.

          Shinobu Kawai added a comment -

          I don't know if this is a good idea, but looks like you can get out by updating the database directly.

          update project
          set state=old_state
          where state=6


            People

            • Assignee:
              Emmanuel Venisse
              Reporter:
              Adam Kiezun
            • Votes:
              3 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development