Continuum
  1. Continuum
  2. CONTINUUM-2666

NPE when removing build agent group via XMLRPC

    Details

      Description

      2011-09-01 15:19:38,129 [qtp25948274-144] ERROR org.apache.xmlrpc.server.XmlRpcErrorLogger - Failed to invoke method removeBuildAgentGroup in class org.apache.maven.continuum.xmlrpc.server.ContinuumServiceImpl: null
      org.apache.xmlrpc.XmlRpcException: Failed to invoke method removeBuildAgentGroup in class org.apache.maven.continuum.xmlrpc.server.ContinuumServiceImpl: null
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcMetaDataHandler.invoke(ContinuumXmlRpcMetaDataHandler.java:163)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcMetaDataHandler.execute(ContinuumXmlRpcMetaDataHandler.java:132)
      at org.apache.xmlrpc.server.XmlRpcServerWorker.execute(XmlRpcServerWorker.java:46)
      at org.apache.xmlrpc.server.XmlRpcServer.execute(XmlRpcServer.java:86)
      at org.apache.xmlrpc.server.XmlRpcStreamServer.execute(XmlRpcStreamServer.java:200)
      at org.apache.xmlrpc.webserver.XmlRpcServletServer.execute(XmlRpcServletServer.java:112)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcServlet.doPost(ContinuumXmlRpcServlet.java:190)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:538)
      at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1352)
      at org.apache.struts2.dispatcher.ng.filter.StrutsExecuteFilter.doFilter(StrutsExecuteFilter.java:85)
      at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
      at com.opensymphony.sitemesh.webapp.SiteMeshFilter.obtainContent(SiteMeshFilter.java:129)
      at com.opensymphony.sitemesh.webapp.SiteMeshFilter.doFilter(SiteMeshFilter.java:77)
      at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
      at org.apache.struts2.dispatcher.ng.filter.StrutsPrepareFilter.doFilter(StrutsPrepareFilter.java:82)
      at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
      at org.springframework.web.filter.CharacterEncodingFilter.doFilterInternal(CharacterEncodingFilter.java:96)
      at org.springframework.web.filter.OncePerRequestFilter.doFilter(OncePerRequestFilter.java:76)
      at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1323)
      at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:476)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:119)
      at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:517)
      at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:225)
      at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:937)
      at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:406)
      at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:183)
      at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:871)
      at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:117)
      at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:247)
      at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:149)
      at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:110)
      at org.eclipse.jetty.server.Server.handle(Server.java:346)
      at org.eclipse.jetty.server.HttpConnection.handleRequest(HttpConnection.java:589)
      at org.eclipse.jetty.server.HttpConnection$RequestHandler.content(HttpConnection.java:1065)
      at org.eclipse.jetty.http.HttpParser.parseNext(HttpParser.java:823)
      at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:220)
      at org.eclipse.jetty.server.HttpConnection.handle(HttpConnection.java:411)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:535)
      at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:40)
      at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:529)
      at java.lang.Thread.run(Thread.java:662)
      Caused by: java.lang.NullPointerException
      at org.apache.maven.continuum.configuration.DefaultConfigurationService.removeBuildAgentGroup(DefaultConfigurationService.java:396)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumServiceImpl.removeBuildAgentGroup(ContinuumServiceImpl.java:2224)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.apache.maven.continuum.xmlrpc.server.ContinuumXmlRpcMetaDataHandler.invoke(ContinuumXmlRpcMetaDataHandler.java:144)
      ... 42 more

        Activity

        Maria Catherine Tan created issue -
        Maria Catherine Tan made changes -
        Field Original Value New Value
        Assignee Maria Catherine Tan [ ctan ]
        Maria Catherine Tan added a comment -

        Fixed in r1164024 and r1164037

        • added a check to prevent NPE
        • added unit test
        Maria Catherine Tan made changes -
        Fix Version/s 1.4.1 (Beta) [ 15104 ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 08:36:01 UTC 2015 [ 1428222961749 ]
        Mark Thomas made changes -
        Workflow jira [ 12711309 ] Default workflow, editable Closed status [ 12740762 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:12:18 UTC 2015 [ 1428268338676 ]
        Mark Thomas made changes -
        Workflow jira [ 12948545 ] Default workflow, editable Closed status [ 12985787 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        46m 17s 1 Maria Catherine Tan 01/Sep/11 08:24

          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development