Uploaded image for project: 'Continuum'
  1. Continuum
  2. CONTINUUM-2502

Master build queue corruption when using

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Open
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 1.3.6
    • Fix Version/s: None
    • Component/s: Distributed Builds
    • Environment:
      RedHat EL 5, Java 6, Tomcat 6
      1 Master, 5 agents on the same account, sharing the same repo and working directory

      Description

      I recently upgraded from Continuum 1.2.2 to 1.3.6 to gain access to the Agent/Paralled build.

      My first setup consisted of 1 master and 5 Agent
      We also have a small utility that add project to Continuum using the xmlrpc library in the form of

      ContinuumXmlRpcClient client = new ContinuumXmlRpcClient(new URL("http://masterDomain/xmlrpc"), "user", "pass");
      AddingResult r = client.addMavenTwoProject(urlToPom, groupId);
      ProjectSummary p = (ProjectSummary) r.getProjects().get(0);
      client.buildProject(p.getId());

      I've imported back all my project from the previous installation by using addMavenTwoProject without an issue. However, when I started to builds on my project with the buildProject method, problems started to occur.

      The master and the agent started to get de-synchronized and the only way to have continuum working again is to restart both the agents and the master.

      Behaviors encountered when the corruption occurred were:

      • The impossibility to launch any more build, the interface returning a success but nothing being added to the build queue;
      • Communication error between the master and the agent, and vice versa through 503 error (trace log included). However, no trace were printed on the server returning the 503.
      • Frozen project status preventing further build, as the project is flagged as building, but the queue remain empty.

      Restarting the master or the agents doesn't solve the problem. Everything need to be restarted.
      A co-worker reported having encountered the same issue when he tried to launch a project group twice while the first build was still running.

        Attachments

        1. master.txt
          18 kB
          Philippe Busque

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              pbusque Philippe Busque
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: