Uploaded image for project: 'Continuum'
  1. Continuum
  2. CONTINUUM-2494

Unable to build a project even though the build agent is there.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.4.0 (Beta)
    • Component/s: None
    • Labels:
      None
    • Environment:
      1.4.0-SNAPSHOT rev. 928661

      Description

      Getting error "Unable to build projects because no build agent is configured" even though the build agent is there.

      Steps to reproduce.
      1. Add a buildagent.
      2. Create buildagent group with the newly created buildagent.
      3. Add a build environment and using the newly create buildagentGroup.
      4. Create project
      5. Set build definition of the project to use the build environment created in step 3.
      6. Build project.( successful build )
      7. Create a new buildagent
      8. Add a new buildagent group with the buildagent in step 7
      9. Add a new build environment using the buildagentgroup in step 8.
      10. Build the project created in step 4.

      Result : page displays "Unable to build projects because no build agent is configured"

      As I have checked after creating the first buildAGentGroup the changes were not displayed in continuum.xml. After adding a new buildagentGroup the continuum.xml has been updated but it only displays the first buildAgentGroup created.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ctan Maria Catherine Tan
                Reporter:
                gautencio Gwen Harold Autencio
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: