Continuum
  1. Continuum
  2. CONTINUUM-2450

Intermittent error when releasing in a distributed build

    Details

      Description

      Tried to release prepare a project and after clicking the 'submit' button, I got a "releaseInProgress.error". No stacktrace at all.

      When I checked the log, the release prepare was actually successful. However, the release descriptor is missing.

        Activity

        Maria Catherine Tan created issue -
        Maria Catherine Tan made changes -
        Field Original Value New Value
        Assignee Maria Catherine Tan [ ctan ]
        Maria Catherine Tan added a comment -

        Did some investigation and found out that the prepared-releases.xml is not populated properly. The prepared-release.xml contains the release prepare information such as the build agent url where the release prepare happened.

        So when the release is in progress, it couldn't retrieve the necessary information from the prepared-releases.xml

        Gwen Harold Autencio added a comment -

        I reproduced this issue only on a fresh installation of continuum and the first project being released.
        I think the PrepareRelease of the first project being released is not added during the creation of the list of PrepareRelease of prepared-releases.xml.

        Maria Catherine Tan added a comment -

        Yes, this only happens on a fresh installation of continuum and during the first release of any project.

        Brett Porter made changes -
        Fix Version/s 1.4.0 [ 15106 ]
        Maria Catherine Tan added a comment -

        Removed if-else statement which is the cause why the prepared-releases.xml is not populated
        r904304

        added selenium test
        r904336

        Maria Catherine Tan made changes -
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 08:36:01 UTC 2015 [ 1428222961749 ]
        Mark Thomas made changes -
        Workflow jira [ 12711094 ] Default workflow, editable Closed status [ 12740572 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:12:18 UTC 2015 [ 1428268338676 ]
        Mark Thomas made changes -
        Workflow jira [ 12947998 ] Default workflow, editable Closed status [ 12983423 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        4d 5h 44m 1 Maria Catherine Tan 28/Jan/10 23:13

          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development