Continuum
  1. Continuum
  2. CONTINUUM-2274

Make wrapper.log roll each day so it won't get too large

    Details

    • Type: Task Task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.3.4 (Beta)
    • Component/s: Jetty Bundle
    • Labels:
      None

      Issue Links

        Activity

        Maria Catherine Tan created issue -
        Maria Catherine Tan made changes -
        Field Original Value New Value
        Assignee Maria Catherine Tan [ ctan ]
        Maria Catherine Tan added a comment -

        fixed in
        r787938 of 1.3.x branch
        r787939 of trunk

        Maria Catherine Tan made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Fix Version/s 1.3.4 [ 15301 ]
        Resolution Fixed [ 1 ]
        Wendy Smoak made changes -
        Link This issue duplicates CONTINUUM-2243 [ CONTINUUM-2243 ]
        Wendy Smoak added a comment -

        Duplicate of CONTINUUM-2243

        Wendy Smoak added a comment -

        How does the fix work-- what config file is affected?

        Will people who keep their configuration files separate need to do anything when they upgrade?

        Maria Catherine Tan added a comment -

        The changes are all in the conf/wrapper.conf file.

        They just need to add the following line
        wrapper.logfile.rollmode=DATE

        and edit the value of wrapper.logfile to
        wrapper.logfile=%CONTINUUM_BASE%/logs/wrapper.YYYYMMDD.log

        Mark Thomas made changes -
        Project Import Sun Apr 05 08:36:01 UTC 2015 [ 1428222961749 ]
        Mark Thomas made changes -
        Workflow jira [ 12710926 ] Default workflow, editable Closed status [ 12740509 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 21:12:18 UTC 2015 [ 1428268338676 ]
        Mark Thomas made changes -
        Workflow jira [ 12947942 ] Default workflow, editable Closed status [ 12983367 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        5m 29s 1 Maria Catherine Tan 24/Jun/09 03:04

          People

          • Assignee:
            Maria Catherine Tan
            Reporter:
            Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development