Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 1.0.2, 1.2.3, 1.3.4 (Beta)
    • Fix Version/s: None
    • Component/s: Core system
    • Labels:
      None

      Description

      I have created a new Maven 1.x project in Continuum and after doing so, edited its project name in the web UI. The edit seems to work fine, but the next time the project gets built, its name gets reverted back to the original name that it picked up from the POM. This is a real pain in the ass because I want multiple Continuum projects created from the same POM (so they are all getting the same name) to do things like building multiple branches, and running different goals on different schedules.

        Issue Links

          Activity

          wsmoak Wendy Smoak added a comment -

          Duplicate of CONTINUUM-2085

          wsmoak Wendy Smoak added a comment -

          Confirmed in 1.3.4.

          The simplest fix is to make that field read-only. If edits are not going to "stick" then don't let people make changes to the project name.

          coolius Patrick added a comment -

          This problem isn't fixed and still in Version 1.2.3.

          The project name is read from the POM and there is no way to dynamically overwrittting it. Passing with arguments is working for maven itself, but not for continuum (e.g. Build 3.4.4-SNASPHOT/Build 3.4.4-RELEASE).

          A simple checkbox: Do not update project name from POM would be great for branches or tags or special builds which need to share the same POM.


            People

            • Assignee:
              wsmoak Wendy Smoak
              Reporter:
              coolius Patrick
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development