Uploaded image for project: 'Continuum'
  1. Continuum
  2. CONTINUUM-2140

Some continuum objects are missing during backup/restore

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.2.3, 1.3.1 (Alpha)
    • Fix Version/s: 1.3.2 (Beta)
    • Component/s: Data Management
    • Labels:
      None

      Description

      Missing backup/restore
      1. BuildDefinitionTemplate
      2. ContinuumReleaseResults
      3. DirectoryPurgeConfiguration
      4. RepositoryPurgeConfiguration

        Activity

        ctan Maria Catherine Tan added a comment -

        Fix in revision 756477.

        • Did not include restoring of RepositoryPurgeConfiguration because of NPE, which is caused by how it is written to the back up file by ContinuumStaxWriter (LocalRepository first before the id)

          People

          • Assignee:
            ctan Maria Catherine Tan
            Reporter:
            ctan Maria Catherine Tan
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development