Continuum
  1. Continuum
  2. CONTINUUM-1953

[regression] Build definitions not linked when creating a new project with a given build defintion template

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.2
    • Fix Version/s: 1.2.3
    • Component/s: Web - Configuration
    • Labels:
      None
    • Environment:
      Linux / Java 1.6.0_10 / mvn 2.0.9

      Description

      When adding a new Maven2 project with the Web interface, I'm associating the project with a given BuildDefinitionTemplate.
      The project is created but no build definition is associated to the project. I need to associate all the build definitions of the template manually to the project.

      It looks like the function AddMavenProjectAction.setBuildDefinitionTemplateId() is never called.

      I have migrated from Continuum 1.1 to 1.2 . It used to work in previous version.

        Issue Links

          Activity

          Wendy Smoak added a comment -

          Confirmed in the 1.2.2 release candidate.

          Wendy Smoak added a comment -

          Added a Selenium IDE test on the 1.2.x branch in revision 709606.

          Olivier Lamy (*$^¨%`£) added a comment - - edited

          You create a build def template, add a maven with this buid def template and cannot see a build def corresponding associated to your project.
          Just tested with the branch and I can't see the issue.
          Do I misunderstand something ?

          Olivier Lamy (*$^¨%`£) added a comment -

          Ping.
          I need more informations : do you add your project to an existing project Group or the project Group is created when you add the project ?
          Thanks

          Jean-Paul GUIGUI added a comment -

          Thanks for your help Olivier.

          Context:
          1. Continuum 1.1 was installed, and later migrated to version 1.2
          2. Problem is on version 1.2. I haven't tested next version.

          How to reproduce the problem:
          1) Create a project group, without any build definition associated
          2) Create a build template with some build definition
          3) Add a new Maven2 project, by assigning the project to the given project group and use the given build template

          Pb: the new project has no build definition associated.

          Wendy Smoak added a comment -

          I can't test this on trunk because on the Build Definition Template page, the arrows to move build defs from the 'available' to 'used' area are not working.

          I did reproduce it on the 1.2 branch as mentioned on Oct 31 with the following Selenium IDE test:
          http://svn.apache.org/repos/asf/continuum/branches/continuum-1.2.x/continuum-webapp-test/src/test/selenium-ide/test_build_definition_templates.html

          Olivier Lamy (*$^¨%`£) added a comment -

          fix in 1.2.x branch rev 725845
          merge in trunk rev 725848

          Olivier Lamy (*$^¨%`£) added a comment -

          reopen as the fix breaks some units

          Olivier Lamy (*$^¨%`£) added a comment -

          I have mode some tests with a 1.1 and comparing with the current 1.2.x branch :

          • adding a project with a builf def template to an existing project group doesn't use the build def from template in both versions
          • adding a project with a builf def template with automatic project group creation use the build def from template in both versions

          It doesn't look to be a regression but more an issue or an improvment
          So do we consider this as blocker to release a 1.2.3 ?

          Olivier Lamy (*$^¨%`£) added a comment -

          Jean-Paul are you adding project with upload file mode or download with http ?
          Because in fact I have found an other issue with uploading pom mode.

          Wendy Smoak added a comment -

          If it's not a regression and you don't see a quick fix for 1.2.3, then bumping it to a 1.3.x is fine with me.

          (I'd prefer to get 1.2.3 out with the things that are already fixed, and I'm not committed to doing a 1.2.4 at this time.)

          Olivier Lamy (*$^¨%`£) added a comment -

          fix rev 726239 in branch 1.2.x
          merge in trunk rev 726243.

          Wendy Smoak added a comment -

          Now when I test this, I do get the build defs from the template, but I also get the default build definition.

          That shouldn't happen. If I choose a particular template when adding a project, only the build defs associated with that template should be added.

          I added another line to the Selenium IDE test to clarify this, and left it in the failing category.

          Do you want to reopen this or handle it as a separate issue?

          Olivier Lamy (*$^¨%`£) added a comment -

          Does it happened when you add the project to an existing project group (an empty project group) ?
          I should say it's normal because when you create an empty project group the default m2 buiid def is associated to this new project group.
          I have created a unit test in core (src/test/java/org/apache/maven/continuum/AddMaven2ProjectTest.java) which check four cases :

          • adding a project with a template to an existing projectGroup
          • adding a project without a template to an existing projectGroup
          • adding a project with a template with auto projectGroup creation
          • adding a project without a template with auto projectGroup creation

          comment added in the unit rev 726462.

          IMHO We should add a new feature : creating project group with a build template

          Wendy Smoak added a comment -

          You're right, it was an existing project group, and it picked up the default build def from the group plus the ones from the template I selected.


            People

            • Assignee:
              Olivier Lamy (*$^¨%`£)
              Reporter:
              Jean-Paul GUIGUI
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development