Continuum
  1. Continuum
  2. CONTINUUM-1909

login and password ignored in checkout operation

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.2.2
    • Fix Version/s: 1.3.2 (Beta)
    • Component/s: SCM
    • Labels:
      None
    • Environment:
      Windows, mac, unix
    • Flags:
      Patch

      Description

      This is what I see in continuum.log:

      2008-10-01 02:00:04,248 [pool-1-thread-1] INFO action#checkout-project - Checking out project: 'RNP', id: '6' to 'C:\apache\apache-continuum-1.3-SNAPSHOT\target\working-directory\6' with branch/tag .
      2008-10-01 02:00:04,405 [pool-1-thread-1] INFO org.apache.continuum.scm.manager.Slf4jScmLogger - Executing: cmd.exe /X /C "svn --non-interactive checkout svn://server.com/RNP/trunk 6"
      2008-10-01 02:00:04,405 [pool-1-thread-1] INFO org.apache.continuum.scm.manager.Slf4jScmLogger - Working directory: C:\apache\apache-continuum-1.3-SNAPSHOT\target\working-directory
      2008-10-01 02:00:06,998 [pool-1-thread-1] WARN action#checkout-project - Error while checking out the code for project: 'RNP', id: '6' to 'C:\apache\apache-continuum-1.3-SNAPSHOT\target\working-directory\6' with branch/tag .
      2008-10-01 02:00:06,998 [pool-1-thread-1] WARN action#checkout-project - Command output: svn: Authorization failed

      Authorization failed because cmd.exe is executed with svn WITHOUT --user and --password options.

      Why so?

      1. CONTINUUM-1909.patch
        1.0 kB
        Carlos Sanchez

        Issue Links

          Activity

          Jimmy Conway created issue -
          Wendy Smoak added a comment -

          What steps did you take to add the project to Continuum?

          I wonder if the 'use cached credentials' checkbox was checked. If so, Continuum is depending on the credentials already being present.

          Wendy Smoak added a comment -

          I can't reproduce this with 1.3-SNAPSHOT r700970 (The 'affects' version on the issue is set to 1.2.1, but the paths in your logs say 1.3-SNAPSHOT, so that's what I tried.)

          I added a project by providing the url for the pom, my userid and password, and not checking the 'use cached credentials' checkbox. I see this in the log:

          2008-10-01 16:58:04,918 [pool-2-thread-1] INFO org.apache.continuum.scm.manager.Slf4jScmLogger - Executing: /bin/sh -c cd /Users/wsmoak/svn/continuum/continuum/continuum-webapp/target/working-directory && svn --username wsmoak --password '*****' checkout https://example.com/svn/wsmoak/hello/trunk 1

          The mailing list is better for questions – please ask on the dev list if you're working with an unreleased version. http://continuum.apache.org/mail-lists.html

          Wendy Smoak made changes -
          Field Original Value New Value
          Assignee Wendy Smoak [ wsmoak ]
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]
          Jimmy Conway added a comment -

          I have Windows environment. Maybe this matters?

          Jimmy Conway added a comment -

          I have this problem for all projects in Windows continuum copy. I use MS SQL Server on Windows.

          I add a project with POM.xml upload as a file. It works perfectly on Linux installation. On windows it executes SVN without credentials (login/password).

          Jimmy Conway made changes -
          Status Closed [ 6 ] Reopened [ 4 ]
          Resolution Cannot Reproduce [ 5 ]
          Wendy Smoak added a comment -

          What version are you using? (The Affects version on the issue is 1.2.1, but the paths in the log statements you posted originally say 1.3-SNAPSHOT.)

          Check the 'About' button in the left hand menu which will show the version and revision.

          Jimmy Conway added a comment -

          1.3-SNAPSHOT, build number: 701593

          This is what I see in 'About' section

          Wendy Smoak made changes -
          Affects Version/s 1.2.1 [ 14539 ]
          Affects Version/s 1.3 [ 14168 ]
          Bertrand Gressier added a comment -

          I have exactly the same thing with continuum 1.2.2.

          You must append your project and if you not specified the good account the first time, It doesn't save the login/password. You can change informations but it don't used.
          In the command line (see in continuum.log) --username and --password aren't writed

          Carlos Sanchez made changes -
          Link This issue relates to CONTINUUM-2006 [ CONTINUUM-2006 ]
          Carlos Sanchez added a comment -

          In CONTINUUM-2006 I've found
          Looking at the code, seems to me that the information in the project is ignored when checking out for all SCM implementations.

          Carlos Sanchez made changes -
          Link This issue is duplicated by CONTINUUM-2006 [ CONTINUUM-2006 ]
          Carlos Sanchez made changes -
          Link This issue relates to CONTINUUM-2006 [ CONTINUUM-2006 ]
          Carlos Sanchez added a comment -

          Reproduced for the perforce scm in continuum 1.2.2

          I think the problem may happen when you add a project without user/password, project fails to checkout, edit project to add user/passwd, continuum doesnt use that information

          Carlos Sanchez made changes -
          Affects Version/s 1.2.2 [ 14684 ]
          Summary svn is executed WITHOUT login and password, why? login and password ignored in checkout operation
          Environment Windows Windows, mac, unix
          Patch Submitted [Yes]
          Carlos Sanchez added a comment -

          Patch against continuum 1.2.2

          Carlos Sanchez made changes -
          Attachment CONTINUUM-1909.patch [ 38579 ]
          Olivier Lamy (*$^¨%`£) added a comment -

          Move to fix version 1.3.1 as we need here a new maven-scm version.
          Carlos your patch looks correct. You don't have karma here ??

          Olivier Lamy (*$^¨%`£) made changes -
          Affects Version/s 1.3.x [ 14168 ]
          Fix Version/s 1.3.1 [ 14741 ]
          Carlos Sanchez added a comment -

          i have, but not sure if it could break something else

          Maria Odea Ching made changes -
          Fix Version/s 1.3.1 [ 14741 ]
          Fix Version/s 1.3.2 [ 14902 ]
          Wendy Smoak made changes -
          Assignee Wendy Smoak [ wsmoak ]
          Emmanuel Venisse added a comment -

          Applied in r.752948

          Emmanuel Venisse made changes -
          Resolution Fixed [ 1 ]
          Assignee Emmanuel Venisse [ evenisse ]
          Status Reopened [ 4 ] Closed [ 6 ]
          Michael K made changes -
          Link This issue is duplicated by CONTINUUM-2220 [ CONTINUUM-2220 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 08:36:01 UTC 2015 [ 1428222961749 ]
          Mark Thomas made changes -
          Workflow jira [ 12710562 ] Default workflow, editable Closed status [ 12740233 ]
          Mark Thomas made changes -
          Patch Submitted Yes [ 10763 ]
          Flags Patch [ 10430 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 21:12:18 UTC 2015 [ 1428268338676 ]
          Mark Thomas made changes -
          Workflow jira [ 12947716 ] Default workflow, editable Closed status [ 12983145 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          7h 13m 1 Wendy Smoak 01/Oct/08 20:12
          Closed Closed Reopened Reopened
          4d 8h 32m 1 Jimmy Conway 06/Oct/08 04:45
          Reopened Reopened Closed Closed
          157d 9h 4m 1 Emmanuel Venisse 12/Mar/09 12:50

            People

            • Assignee:
              Emmanuel Venisse
              Reporter:
              Jimmy Conway
            • Votes:
              2 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development